Hot Roddicus Supersonicus
Im genuinely getting it handed to me with this C68 Canadian Electronic AC.
Car had a restoration prior to me getting it and the Ac wasnt working. Nearly everything is new.
Ive put in enough freon to trigger the compressor butit wont turn on. I traced the power wire to the compressor back to just before the ac relay. Its light green. If I hit it with 12v power goes through the pressure cycling switch on the accumulator and the relay to the compressor and the clutch engages.
I know the control head isn't cheap and there are a few guys with them. I know caspers sells the AC blower control module 107146 also. I have more than a few schematics and trouble sheets but its just still not showing me the issue. On top of that I have 2 plugs that look like piggy backs that sit behind the control unit with no purpose. Not sure if the should be going somehere. They are orange and grey wires eventually running to C3.
Ive done checks at the control head and the contol module. In both cases im missing power when I need it. The purple wire from the control head to the module has no voltage. The other 3 wires have 12v.
Im attaching a few pics of what Ive diagnosed, the two plugs going no where, and some docs.
If anyone knows this stuff please let e know if you see something.


  • 289928229_7735388283198953_9215613799486830702_n.jpg
    119.2 KB · Views: 97
  • 289713681_7735388256532289_8684564692082783364_n.jpg
    106.2 KB · Views: 102
  • 289781052_7735391063198675_3409739637089331229_n.jpg
    594.5 KB · Views: 119
  • 289655098_7735391053198676_704776723916333292_n.jpg
    293.2 KB · Views: 103
  • 289842408_7735388343198947_4899577227711696110_n.jpg
    252.3 KB · Views: 100
Sorry I can't help with the A/C issue.

I want to say the grey wire is for the Limited dash plaque lighting. Is it possible the orange is the wire to supply power to the grey for the dash plaque?

Wish I could be of more help.
Have you checked the ECM-SOL fuse? just had an issue trying to get my ac functional and the pink/blk wire had no power, the ECM-SOL fuse was the culprit, right next to the A/C fuse on block, 10 A
Thanks I tried all the fuses and theyre all good.
Im leaning towards the head unit since I was able to verify all the power is getting to the headhunt and the grounds are good.
Id like to convert to Fahrenheit
Yes 134a
according to the schematic the high pressure switch cuts the ground to the compressor.
I have solid ground to the compressor I have no power to it


  • Screen Shot 2022-06-22 at 11.10.28 PM.png
    Screen Shot 2022-06-22 at 11.10.28 PM.png
    1,012.6 KB · Views: 93
The purple wire needs the proper control voltage on it, 5-7 or 11-13.
All the tests seem to require it to be over 60 degrees temp. outside was it?
Did you measure the purple wire voltage at the control head itself to eliminate the wire going to the next module? Schematic doesn't show where that voltage is generated from in the control head most likely it's defective if the other signals are there properly.
I checked the purple wire at the control head and theres no voltage there. Its hot so Im way over 60. Purple wire goes straight the ac/bower control at the blower. I checked the ohms and the purple wire is good.
would be nice to have a loaner control unit to try and plug in, does it open up? I would be poking inside it to see if it's able to be troubleshot.
Mario, when you've taken your troubleshooting as far as you can, reach out to John S. at Casper's and Richard C. at Richard Clark's Garage for further assistance.
Yes 134a
according to the schematic the high pressure switch cuts the ground to the compressor.
I have solid ground to the compressor I have no power to it

Does the switch say R12 or 134A on it?

I think that info is in between the prongs on the switch, IIRC.