maft+

luisturbog

UNDERDOG HOT AIR !!!!!!!
Joined
Mar 30, 2007
Does anybody know if the only way to run a maft+ is to have a chip burned or will it run on a stock ecm? 84/85 ecm. I installed mine and car did not want to run; anybody have any ideas?
 
I'm thinking you need an 87 ECM...

The translator should work with any chip...
 
I finally got it right! Well the maft+ does work with my stock 84 ecm, I actually had my wires crossed, thats why it would not run. Fired it up with it wired correctly, just got to get it fine tuned. Settings on it had to be changed. I took 2 degrees out of base timing and it runs better. does anybody know if everything is set at factory settings should my car run like it did before the maft+ or should it run different? I'm mechanicly inclined but this is mind boggling!!!
 
I finally got it right! Well the maft+ does work with my stock 84 ecm, I actually had my wires crossed, thats why it would not run. Fired it up with it wired correctly, just got to get it fine tuned. Settings on it had to be changed. I took 2 degrees out of base timing and it runs better. does anybody know if everything is set at factory settings should my car run like it did before the maft+ or should it run different? I'm mechanicly inclined but this is mind boggling!!!


I have a 85 GN with a LS1 maf and translator.. works awesome with the TT chip too...

still using stock ECM
 
settings

I know every car is different but what do you have you maft set at and what injectors do you have?
 
Top