SpeedPro Fan and Fuel Pump control problems...

carbuff

New Member
Joined
Sep 30, 2001
Hi all,

I'm having a problem with my SpeedPro ECU. I wired up the fuel pump wire to the ground side of my Fuel Pump Relay, but it doesn't appear to me making a connection to ground for me. I confirmed that this wire, when grounded, will enable the pump. But the SpeedPro doesn't seem to do the trick...

Can anyone tell me what to do or check? I haven't found anything in the C-Com that enables/disables the fuel pump, other than the prime time (which I'm not exactly the function of).

I tried to perform a continuity test to ground, and I don't get a connection to ground when I power up the ECU. I don't get one through either the Fuel Pump or Fan wires... Should I?

Any advice? Is it possible that my drivers are bad? How would I test for this? The ECU seems to work otherwise, and the sensors seem to be working as well....

Help!?

Bryan
 
Since you don't say what kind of car or what sort of installation, it's kinda unclear what the problems could be.

As you could well understand, the ECU will only enable the fuel pump when the engine is cranking/running, or when the fuel system is priming (when you first turn the car on before starting it). One way to check it is to set the prime time to like 20 seconds so you can turn the key forward and have some time to go look for the ground.

A few things to keep in mind:

1) The ECU will usually not re-prime the fuel pump if you just flip the ignition off then on. You should leave the key in the off position for 3-5 seconds before you turn it back on.

2) The ECU will ground the "trigger" side of the relay, not the "power" side. Don't forget to have +12V hooked up to the positive side of the relay!

3) I doubt the ECU is bad. They aren't perfect, but I'd bet that whenever people ask that question, 99.5% of problems actually lie somewhere in the installation and not in the ECU. Do some other double- and triple- checking.

4) There should be continuity to ground when the fuel pump is supposed to be running.

Let us know what you find!

-Bob Cunningham
 
Thanx Bob.

The car is an old Camaro with a SBC that I've built. The fuel pump is an aftermarket intank unit with a Hella relay. I have +12V connected to the positive trigger of the relay. I have the ground trigger connected to the SpeedPro.

I upped the 'prime' value to about 5 seconds. Maybe I didn't leave the ECU turned off long enough though. I will up the value more and ensure that it's off long enough.

Is it correct that when the ECU comes on, the ECU will ground the Fuel Pump wire for the amount of time set in the 'prime' setting, and if the engine is not running by then, it will turn off the pump?

Like I said, I know the relay and pump are working because I can ground the wire and the pump runs...

I'll go recheck and retry to make certain the ECU was off long enough today.

Thanx!
Bryan
 
"Is it correct that when the ECU comes on, the ECU will ground the Fuel Pump wire for the amount of time set in the 'prime' setting, and if the engine is not running by then, it will turn off the pump? "

Exactly.

FWIW, I have mine set to prime for 1 second. If I am troubleshooting, I up the time to 25 seconds (or whatever the max is), but then reset it to 1.

Only other things that I can think to check are 1) Is the relay working (which you say it is), and 2) is 12V+ hooked up to the "power" side of the relay?

Besides that, you should have continuity to ground when the fuel pump is on.

Also, I'm not sure, but there might be an indicator on the "big" dashboard (hit F9 if you have the DOS version of Calcom) that says if the fuel pump is activated.

-Bob Cunningham
bobc@gnttype.org
 
Spent more time working on it today. Same conclusions as before. The fuel pump relay works fine when I directly wire the trigger wire to ground. Does not work when connected to the ECU.

I disconnected the wire from the ECU, and I still don't get continuity to ground when I power it up, so I don't think the relay is at fault...

Numbers from the ECU directly:

Part# 30-113010
Serial# 0391 379
Dealer# 056
Batch# B
Firmware Rev B2BIPU_f
Option B2B WB
Date of manufacture: 021898 -030200

I purchased this system is the summer of 2000. I just installed it about 3 weeks ago to start the motor (project taking longer than expected, of course). I just tried to get the fuel pump working this weekend (had it hard wired previously and not connected to the ECU).

Any other help/advice?

Thanx!
Bryan
 
Well it sounds like you did exactly what I would do- turn up the "prime time" and check for a continuity to ground, so now you've stumped me! Try giving your dealer a call for some additional insight. (If you bought it used, call whoever you bought it from and make sure they didn't accidentally ground the pump itself instead of just grounding the relay, in which case it's probably an ECU problem...) If you bought it new and the ECU doesn't work, then find out about getting the ECU fixed through the dealer.

Please let us know what you find!

-Bob Cunningham
bobc@gnttype.org
 
You won't necessarily get continuity to ground with a digital multimeter as the output of the ECU is grounded by a NPN transistor. This output will sit slightly above ground when active so depending on what resistance or which way you have your leads hooked up (= voltage on meter) you might or might not get a continuity beep / reading. If you have a small test light connect the clip to B+ and touch the probe tip to the O/P of the ECM and see if the lamp comes on. The relay should be disconnected during this test.

Using a relay which requires to much current might also cause problems. The coil on your relay should measure around 90 ohms.
If the relay used happened to have a diode on it and it was hooked up backwards at some point that could have fried the output from the ECU.

Have you tried the fan control yet?
 
Continued thanx for the help guys... I'm still stuck though. :(

I tried the leads on the DVW both ways just to make sure. No difference. In a voltage test, I seem to see somewhere around 4-5V on the fuel pump lead. Seems to always be the same...

As for the relay, I'm unsure about whether it had a diode in it. I'll have to look.

I haven't been able to try the fan control in the sense of hooking it up to the relay. (all the wiring isn't in place yet). But I get the same result as above. No continuity to ground and a voltage on the wire coming from the ECU.

Sigh...
Bryan
 
Here's the deal on the fan/fuel pump/N2O outputs:

They are "open collector" output drives. This means the outputs switch to ground. It would be like one side of a SPST switch where one pole is permanently connected to a ground. When the switch is open (off), the opposite pole will be at whatever level or voltage potential is present. if looking at the coil of a relay, and one side of this coil is at 12V, the other side of coil will be at 12V as long as the switch is open (off) and will drop to ground potential when the switch is closed (on). Since the driver in the ECU is solid state, there is no way to use an ohm meter to check the funcionality of the drive circuit. Use a volt meter and monitor the drive (ECU) side of the relay. If that point is 0V all the time, then the drive is either commanded on or stuck on (ie. fan on all the time), the relay coil is open (faulty), the other side of the relay coil is unpowered, or a bad connection anywhere in the circuit. If the output is at 12V continuously and the output is commanded on, then it's likely that the driver is bad and the ECU requires repair.

If the drive output is ever connected directly to a 12V power source or connected to a device that draws over about a half an amp, the driver is likely to be damaged and the ECU will require repair.

The driver capacity is actually difficult to explain here as it's somewhat dynamic with the number of drives currently in use. If using only one drive (ie. fan) the drive capacity is about 750mA max., if using 2 drives (ie. fan and pump on simultaneously), the capacity falls to about 500 mA max. By the time you reach 4 drives on simultaneously (fan pump, 2 stages of N2O), the capacity of each drive is reduced to 250mA max.

A typical relay will draw about 165mA at 13.5 volts.

I hope all this helps.

Lance
 
Hi Lance,

Thanx for the response... Everything you said makes perfect sense. I actually play an EE everyday in real life! :)

Somehow I have a feeling these drivers are blown, I'm just trying to confirm it before I deal with having the unit repaired. If I have to go that route, what's teh best way to go about it? As I remember, my dealer for this box is no longer a FAST dealer unfortunately... :(

I will go back tonight, reinstall the relay, and check the voltage at the ground pin of the relay when the box is powered up. I know the cirtuits are good since I can directly ground this wire by disconnecting it from the ECU and the relay works.

Thanx again for all the help! I will get this worked out... :)
Bryan
 
I too am having a problem with the fan. I Have a SEFI8LO bank to bank system and have the pinout listing for the ecm. I have the fan control wire from the ecm going to the original dark green (pin d2) wire of the original harness. I have the pte adapter harness. Not that this matters. I have tested from the relay down to the harness. The relays are fine. I cannot however get the ecm fan control wire to ground. I have it hooked up to a test light with the other side of the light hooked up to 12v. I ran the car until it got to 177 degrees on CCom. It was set to come on at 168 degrees. Got nothing. This tells me its not triggering. What can I do? are the drivers bad????

I also wanted to mention that I have my AC entirely removed. I have a hi/lo switch hooked up and when I hit the low on the switch, i hear the relay click but get nothing. could this be something with any of the ac wires disconnected?????

Scott
 
Top