eric help!!!!

QUIP'6'

Brian Roman
Joined
Nov 26, 2003
hey eric this is brian. i just got my heads and intake back from kn performance and they are race ported and i got the motor running and remember the problem i had with the low 02's well now the idle is smooth and the o2's in park are high 600's before they wer 100 to 400 and a rough idle and they wouldt lock on. so something with my old intake or heads caused that problem. you said it was mechanical. the question i got is that with the ported heads would there be a leaner idle circuit and do you need to add fuel for a richer idle because of more air and would that bring the 02's up? i need a new chip for the heads and bigger turbo anyway just wanted to know if it would bring the 02's up. also my crosscounts stop unlike before when warmed and idling in park. my blm's are 123 and fuel pressure at 45. hope all is well
 
Hey Brian,
Sounds like there was some sort of air leak going on with your old setup. Glad it's fixed!
As far as idle, we don't need to change the chip for that. The MAF sensor will pick up any airflow changes (up until 255 gr/sec). We will need to adjust for WOT though. On some cars the idle O2's read lower. Basically, as long as it stabilizes somewhere over 500, then we know it's slightly richer than 14.7 a/f, and it should be ok.

Eric
 
Hey Brian,
Sounds like there was some sort of air leak going on with your old setup. Glad it's fixed!
As far as idle, we don't need to change the chip for that. The MAF sensor will pick up any airflow changes (up until 255 gr/sec). We will need to adjust for WOT though. On some cars the idle O2's read lower. Basically, as long as it stabilizes somewhere over 500, then we know it's slightly richer than 14.7 a/f, and it should be ok.

Eric

thanks for the quick response eric. i will send the chip in soon since my chip is setup for a ta49 and stock heads now i have a te60.
 
Top