LM9 No start help.


This is the way.
Hot air, no start.


Recently bought this 85 GN. Noticed a newer crank sensor but didn't think much of it (old one in box in trunk). Have not driven it except off the trailer, and in and out of the garage once.

A few days ago, back it out of the garage and shut it down. Then it cranks but no start. (Good fuel pressure at the rail, dry plugs) Ran through all the C3I checks in the factory manual with test light and/or meter, and the tree clearly pointed at crank sensor.

Just to confirm, I hooked up my Caspers C3I box, no crank signal. (Power and cam good)

Replace crank sensor set gap to .030.

With box hooked up, it started and ran with the lights showing proper sensor operation.

Removed box and hooked up 14 pin back to the icm, cranks but no start again.

Reconnected Caspers box again, crank signal is now gone, again. (Power and cam good)

(Counting the old one in the trunk, that's 3 crank sensors in a short period of time.)

After I rotated the ring to the position is should light, I did a serious wiring shakedown with key in run to see if I can see something flicker, nothing.

Ohmed out the crank and 14 pin connectors, all checked with no or inconsequential resistance and rock steady...

I also tried swapping in another known good ign/coil pack, a good ESC module and relay, still no

All the parts that this began with went back in after there was no change.

I'm open to ideas. Thanks!

Sent from my Spaceship.
Are you using the stock ign module?
If not;
Are you using the conversion harness?
Are you getting injector pulse?
If you spray a little fuel in the tb, does it fire?
Fuses good?
Are you using the stock TPS? Value koeo is. . . ?
Thanks for the reply Jerryl,

I tinkered more last night and again with the Caspers box hooked up it fired right up with all sensors reporting. I'm going after an open (suspected) expanded female pin in the 14 pin connector, I think its a connection issue. I'll carefully extract them and rebend to tighten up the contacts. It firing back up just showed me the replacement cam sensor is still functional which I'm pleased about.

As for configuration, it came to me with an 86-87 ICM/Coil Pack and harness that once the no start BS started I swapped with my known good 84 ICM/coil pack and ECM (no adapter harness of course). If I can isolate this intermittent connection and repair it I'll decide if I want to go back to the newer style.

In the above process I did spray ether during a start attempt with no results.

No injector pulse (when box shows no crank signal), Fuses good, stock TPS is right on the money (cant remember exactly I have the book at home, but it was checked) the IAC was reset according to the factory book and I can hear it running.
Connection issue for sure, each pin got extracted and pinched slightly. Definite positive contact now, I wiggled each wire specifically while running to get it to fail and its good ...

Starts right up now but when the RPMs slowly drop at idle it gets a little rough. That may be a whole new issue. Thanks though!
No PL, I use the 1320 adapter and ALDL Droid. I have not had an opportunity to hook it up yet. i'll do it today when I get home.
Stock HA MAF? I would try another if you are not seeing around 5-6 gr/sec @ 750-835 rpm idle.
Yup HA MAF. Will do. I got done last night real late and was gonna get the adapter and my phone. I said to myself, if I leave the garage I'm going to bed haha.