PowerLogger flash issues


Active Member
May 25, 2001
So I finally started tinkering with car again. I have managed to follow directions enough to get the newest version of the PLC up and running in my Windows 10 laptop. However when I try to reflash the PL interface something fails.
I'm currently running PL 2.0 according to my Scanmaster on startup. When I try to flash with the 051 file it connects and syncs for a while, then just stops without completing.
Any tips?

Sent from my XT1254 using Tapatalk
look in device manager and see what ports appear. is your PL black or green?

I believe it was 3. The PLC works in monitor mode. I just get a warning when trying to save log files. I think the board is back.

Sent from my XT1254 using Tapatalk
what warning are you getting when saving logfiles?

the update function was written back when XP was king, and the newer windows have much longer file paths. copy the flash40.exe and the .s19 file you are trying to update with to c:\ and see if it will update that way.

if you are getting warnings when trying to save something, make sure you are not running PLC from the CD or from a compressed folder.

OK, So i did some more playing around and I solved one issue but created another. I missed the part about being in monitor mode while flashing the PL. So I got that to work, or so I thought. I was able to flash the PL to version 5.1, however now my Scanmaster now does nothing. On startup it shows SM 2.2 but when it's supposed to display the PL version it does so 2 to 3 times with different version numbers displayed, none of them being 5.1. They are just random numbers, then it goes blank.

The PLC is working fine now, it monitors and saves like it should. It displays PLC version 2.6.8 and Interface version 5.1 when connected.

However when I tried to reflash the PL again to attempt to fix the Scanmaster issue, the PLC drops communication and stops monitoring as soon as I hit the FlashPL button on the help screen.
Jeez, Why didn't I think of that. :) I unchecked the Scanmaster G box and all is well with the Scanmaster now.

Still disconnecting when I try to Reflash PL though. Not sure what that's all about.
you don't want to be monitoring when you reflash. you do want the port selection to be correct. I uncheck the "auto" box on the 3 page once the port has been figured out, it makes the connection step a little quicker.

So, do this: run PLC, start monitoring, after monitoring has started, hit Esc to stop it, then uncheck the auto box on the F3 page. (leave it unchecked when you are done)

then go to the F1 page and reflash the PL

OK, Trying it now. It seems to be looping on the "communications Synchronized" line it just continuously prints that line all the way down the flash window.

Tried it a few times, never seems to get past that point.
Last edited:
wierd, I've never seen that. can you take a pic of the screen?

Here are 2 screen caps. One shows PLC monitoring normally, the other showing the com sync loop. It will keep repeating that for a minute or two then just hang up there.

PLC Monitoring.png Pl Flash Loop.png
seems more like a windows port issue to me. The software has not changed in years, so I'm not sure whats causing that.

Can you try a different computer?

In any case, I can always update it here for you.