Turbo-Link spitting out Turbo Garbage - Only My TR :\


- driving everywhere -
May 25, 2001
I have Turbolink running on a Acer TravelMate 512DX laptop in MS-DOS mode.

I have scanned Ryan A. 's 86 GN engine, Leon W.'s 86 T-Type and another friend Bob B.'s 86 GN without any problems....

However, with My 87 TR, after a few seconds of scanning, it starts spitting out crap data.

I have done the following:

1. Rebuilt ALDL connector by cleaning and tightening pins

2. Cleaned ECM connectors

3. Cleaned, lubed with dielectric grease and tightend contacts in IP connector to the right of glove box

4. Have backprobbed ECM A8 terminal and connected to ECM case/ground and hooked direct to T-Link cable with same "garbage" results.

5. Have changed ECMs

6. tried stock chip, despite having Ford Blue Top injectors, still spit out garbage

7. Reviewed pins on both chips

8. Replaced battery wires with 2-gauge, battery negative wired directly to crossmemeber/chassis and motor tied to this ground point via Taylor 4-gauge ground strap, additional 4-gauge ground strap on driver's side of engine tied to frame, alternator wire upgraded to 4-gauge with gold-plated contact...power is good :)

9. Replaced and cleaned deteriorated and corroded ground connections at back passenger-side of engine

...so...any ideas? I have the tlink .xls file i just recorded, 30 frames showing the garbage.

My car is suffering, aside from garbage output...poor idle and light throttle quality and slow spool up from my stock turbo. IAC pintle and bore is clean, tps is set at .42vdc at idle, o2 sensor is a new GM unit and is a few months old.

HELP!!! :confused:
What is the service number on the ECM? Is it 1227148?

Does it spit out garbage if the key is on and engine is off?

Do you have tlink set up properly? ie: Buick LC2 and not a TBI chevy for example?

Have you tried printing with the laptop to verify the LPT isnt f'd?

Have you tried another laptop?

Have you looked on Kens page (turbo-link.com) to see if there are issues with the model PC you're using?

Have you checked in BIOS to make sure ECP/EPP is selected for the port mode?

Send me the ECM file NOT the xls or csv file. Let me look at it.

Lets start here......
Originally posted by kenmosher
Great ideas from Jim ... as usual...

Does your chip perhaps have the ScanMaster patch? Is the the data consistently "hosed"? Or does it have some good frames?
Ken, the file he sent me is normal for approx 4 frames, then pukes. I cant be my chip as 1) it doesnt have scanmaster patch, and 2) Isnt consistant, keeps blurting out wrong info, no rythum, No consistancy 3) and I do nothing to the data stream. . I honestly suspect a batt cable shorting or such, but generally he'd have a SES light blip or other hiccup. I suggested privatly he run a TCC jumper at the ALDL, and measure voltage drop on the ground with the circuit loaded. If OK, then trying a seperate run from ECM term A8 (serial comm) to the ALDL. If THAT dont work, buy a yugo :)