Well Kids, I'm pretty excited!!

TurboTGuy

Gray Beard Member
Sep 24, 2010
4,305
1,901
113
Phoenix, AZ
So, I believe I/we have worked out all the gremlins that were keeping me from going WOT on this new engine AND may have fixed the Fuel Gauge issue.

Another trip to work tomorrow, a 22 mile each way trip, both city street and freeway driving, will help confirm and the high is only supposed to be 99* tomorrow, so that will help. A nice cool morning high 70's drive........

Wish me luck, folks, please......

I'll update tomorrow evening......... :)

If all of it works to my liking, a dyno session is in order to make her run peak street and strip boost levels.... :cool:
 
Last edited:

T- Type Tim

Vice Chairman
Jul 8, 2001
1,613
258
83
43
Chandler AZ
Yeah
Making your drive from phx to Scottsdale is not one I would do in the Buick on a weekday. Way too many idiots seem to be on our roads around here
 

TurboTGuy

Gray Beard Member
Sep 24, 2010
4,305
1,901
113
Phoenix, AZ
Not up in Scottsdale these days, running our Tempe opperation for a while.

51& Glendale to the 10 - 10 to Warner in the morning...Opposite on the way home.....

Scary in the best handling of cars. :p
 

TurboTGuy

Gray Beard Member
Sep 24, 2010
4,305
1,901
113
Phoenix, AZ
Dang, still have a gremlin.

My friend Dennis is coming over tomorrow to help see if we can sort it out. we'll logs some blasts down the freeway and see what we come up with.
 

TurboTGuy

Gray Beard Member
Sep 24, 2010
4,305
1,901
113
Phoenix, AZ
Need real data, that will happen tomorrow. Maybe a F/P issue, maybe a rich issue, maybe an ignition issue.

You know these cars. Never got it to Joe to check out, next week though.....I'll get it sorted out soon. I have a lot of great support people at my fingertips. I just need to provide them good/valid info. :)
 
  • Like
Reactions: grass doctor

TurboTGuy

Gray Beard Member
Sep 24, 2010
4,305
1,901
113
Phoenix, AZ
So here's what we found.

FP - Good
Plug Gap - Correct
Coil Pack - Good
Ignition Module - Good
Knock - why so much, what's vibrating? Took the turbo heat shield off and knock went away. It was hitting the downpipe.

Still not running right.

ECM - Hmmmmmmm

Swapped it out for a new one I had Bob Bailey modify a while back and V'iola! The car runs like a scalded dog! I mean harder than it ever has. And that's while running out of real estate on every pull, being as we were on the freeway doing our testing.

Now I just need to tweak the alky this evening when it cools off some and I'm set to kill. ;)

I knew this combo would be the shit!!!!!!!!!! Couldn't be happier!
 

SpeedRacerX

Well-Known Member
Jan 20, 2014
1,086
334
83
51
Southern NJ
So here's what we found.

FP - Good
Plug Gap - Correct
Coil Pack - Good
Ignition Module - Good
Knock - why so much, what's vibrating? Took the turbo heat shield off and knock went away. It was hitting the downpipe.

Still not running right.

ECM - Hmmmmmmm

Swapped it out for a new one I had Bob Bailey modify a while back and V'iola! The car runs like a scalded dog! I mean harder than it ever has. And that's while running out of real estate on every pull, being as we were on the freeway doing our testing.

Now I just need to tweak the alky this evening when it cools off some and I'm set to kill. ;)

I knew this combo would be the shit!!!!!!!!!! Couldn't be happier!
Awesome. Have fun and be careful.

So what goes bad in the ECM? What do you think the ecm was or wasn't doing properly? Just curious.

Sent from my SM-G965U using Tapatalk
 

TurboTGuy

Gray Beard Member
Sep 24, 2010
4,305
1,901
113
Phoenix, AZ
Awesome. Have fun and be careful.

So what goes bad in the ECM? What do you think the ecm was or wasn't doing properly? Just curious.

Sent from my SM-G965U using Tapatalk

Dennis explained that sometimes it's the Powerlogger that will cause problems, the one that was in the car had been there for almost ten years and had been moved around quite a bit in all those years, re-glued a couple of times, too. Who knows? I'll check it all out when time allows.

The new ECM I put in the car was modified for low impedance injectors (I'm thinking of going bigger than the 80's I currently run, so this would be necessary) AND I had Bob install new Powerlogger while he was in there.
 

TurboTGuy

Gray Beard Member
Sep 24, 2010
4,305
1,901
113
Phoenix, AZ
So, Joe Telesca came over this evening to check out and make sure the fuel system he designed was up to par. Service after the sale!

All is good!


Tomorrow, another drive to work is in order, maybe tearing up a few side streets in the area as well. High temp is only supposed to be 86* tomorrow and it stopped raining about an hour ago..........

PL and computer is ready to go, co - worker - co - pilot/logger is excited to be gettin' a ride up in this thang. :cool:

I'll report back tomorrow!
 

TurboTGuy

Gray Beard Member
Sep 24, 2010
4,305
1,901
113
Phoenix, AZ
Aight, and???


Sent from my iPhone using Tapatalk

Gremlins......... Dang it. And my laptop died so no logging this afternoon..... used the PL to diagnose but couldn't pin point it.

Back at it with Dennis tomorrow. We'll get it sorted out. He's a smarter guy than I am.