87 gn spit under load

dgreen

Member
Joined
Dec 4, 2011
just install turbo tweak 42 #injectors and chip, under heavy accel spits. dont have scanmaster yet boost set at 15 psi 93 octane sunoco fuel it was doing this before chip and injectors fuel pressure set at 42psi w/vac hose unhooked any help would be appreciated!!!!
 
you can use the diagnostic terminal to get your codes or borrow a dia. meter from someone to help diagnos problems. If I remember correctly, it would be shorting pins A to B on the diag. terminals. Turn the key to "on", don't start the eng. The check eng. lite will flash, count the number of flashes to get the code. The long flash represents the double digits and the short/quicker flashes are the single digits. i.e. one long and 2 short=12, 3 long 4 short=34
Hope this helps.
 
with boost lowered to 13 psi does not seem to do it (although car does feel slower) i'm clue less on this one ,i think i'll try a coil. Was out today driving car and brake light came on along with noise from hydro boost pump, looked under pump and lots of brake fluid running out of it. Now i guess i'll have to buy a hydro. unit!!!! NAPA wants $410.00 for complete unit with master cylinder anyone have a used one?
 
with boost lowered to 13 psi does not seem to do it (although car does feel slower) i'm clue less on this one ,i think i'll try a coil. Was out today driving car and brake light came on along with noise from hydro boost pump, looked under pump and lots of brake fluid running out of it. Now i guess i'll have to buy a hydro. unit!!!! NAPA wants $410.00 for complete unit with master cylinder anyone have a used one?

Check our "parts for sale" section and ad for one in the "parts wanted" section.
 
a/c plugs have been in for about 8 months. The power master for sale looks like it has issues! I think ill swap to a vacuum booster .
 
It's not unusual to see brake fluid leak out the pm when the fuse blows.
99% of all powermaster units get overfilled with fluid. This because the passenger side of the reservoir is the power assist fluid and appears to be low when the system is actually full. Your pm fuse prolly blew. From there the fluid goes back into the reservoir each time the brakes are applied. The result is fluid overflows out the top.

Like chuck says. Make sure fuel pressure is rising with boost. Also make sure no leaks in the maf pipe.
 
Top