bad knock sensor?

Vendor Defendor

Out the window
Joined
Nov 25, 2002
how can you tell if a knock sensor is bad? can it cause false knock? i am chasing this knock problem that i have but i cant seem to find it.

i turned down the boost from 24psi to 14psi and i am still knocking crazy, well, i saw 5 degrees of KR while on a short run. o2's were in the ball park of 840's

fuel pressure is set at 44psi LINE OFF

alky comes on at 11psi

what really confuses me, is i had this car running perfect last week, it was running 24psi with 0 kr. so i figure its got to be false knock, espescially since i am knocking that bad at only 14psi on 93 and alky.

could the knock sensor be bad? i cant tell or not, but one of my tail pipes may be rattling, i dont hear it at WOT.. dont know this has me chasing my tail.

thanks for any advice :confused:
 
Bad MAF
Bad plugs
Bad Coil pak
Dirty fuel filter
,,
what have you changed/checked already.
 
Originally posted by AsphaltAnihil8r
Bad MAF
Bad plugs
Bad Coil pak
Dirty fuel filter
,,
what have you changed/checked already.

fuel filter is about a year old, the plugs are about 2 months old. the MAF, a mechanic friend of mine said it was ok by checking the readings on the scanmaster.. dont know about the coil pack. would the alky coming on too soon give me knock? i could try shutting the alky off and seeing if it still knocks at 14psi...

thanks
 
Yes running rich like you are and adding the alcy to the mix will cause a rich knock,I had the same problem.......
 
I once had a MAF read correctly (SM) but under any boost it would run like Sh!t,knock ,bang ,clng ,you name it ..
 
well, tomorrow i will shut the alky off to see if that is causing any knock while i am running the 14psi. and what should my MAF read at WOT?

thanks
 
humm, according to that check list you sent me, my alternator isnt charging in the area that it says, mine is charging low to mid 13's at idle...

oh yeah, and the check list also says to make sure that no wires are touching the knock sensor, can a wire touching the knock sencor set it off?

and how much do knock sensors go for? thanks
 
Will your alt charge properly when you slightly rev motor?14 to 14.5 volts?If yes then you should be ok.Try to get any cables or wires away from sensor tv cables tend to rest on the knock sensors if originals brackets are missing.I just bought a new sensor this past summer it cost me about 50 dollars Canadian.Check out Caspers for a knock sensor or stock GM only.Make sure your pos bat cable is not touching frame close to starter or on the engine mount this is a common problem.
 
humm, might have it figured out, as Fast Eddie had said about the alky coming on too early, well, he may have been right:

apparently i had my alky coming on at 11-12psi, but then some gremlins got into my car and started messing with stuff and turned the alky down to about 5psi :eek: turned it to come on now 12-13psi and i saw 824mV and 2.8 Kr w/ 15psi

so at least i am headed in the right direction right

my MAF at about 3/4 throttle, enough to be in boost, showed 222 on scan master, so i dont know exactly what it will be at WOT.

i forgot to check to see what the battery is charging at.. whoops.

how do i know if an o2 sensor is bad? well, i will post another thread about this later on, thanks for all the help
 
Top