Car hesitating

NY_GN

Planning next secret evil upgrade
I had spares so I changed;
MAF
IAC
spark plugs cam sensor
O2

Blew header gasket and changed that too.

In closed loop it drives great, as soon as it goes into open loop it hesitates and sputters. if I keep giving it has it will power thru, but that's not sustainable. all numbers on scanmaster and FP gauge check out.

Gonna try spare ECU next.

Any suggestions? I checked the old threads, only one with good answer was replaced ecu.
 
My car sputtered between 30-40 mph. A new crank sensor fixed it. But open/closed loop had nothing to do with it on my car.
 
My car sputtered between 30-40 mph. A new crank sensor fixed it. But open/closed loop had nothing to do with it on my car.
crank sensor at the 4 o'clock by the balancer? is there a way to test it?
 
New I had spares so I changed;
MAF
IAC
spark plugs cam sensor
O2

Blew header gasket and changed that too.

In closed loop it drives great, as soon as it goes into open loop it hesitates and sputters. if I keep giving it has it will power thru, but that's not sustainable. all numbers on scanmaster and FP gauge check out.

Gonna try spare ECU next.

Any suggestions? I checked the old threads, only one with good answer was replaced ecu.
What are the wide and reading when the sputtering happens?is it rich or lean?
 
Is the car hard to turn over?does the turbo not want to make boost?
Fires up fast, when it's not sputtering it spools great and alky comes on at right time.

I had blown gasket at header to turbo, changed it out and spools better than ever.
 
Is the sputtering at a consistent rpm and fuel pressure?ex: 3800rpm and 50psi on the rail with low boost and alky coming in?
 
Is the sputtering at a consistent rpm and fuel pressure?ex: 3800rpm and 50psi on the rail with low boost and alky coming in?
No, its unpredictable, it happens at random times like a misfire, but when i punch it, it powers thru. it feels like a bad maf type miss, but i put 2 known good mafs on. the fact that it only hapoens in open loop leads me to beleive its a sensor.
 
Random sputtering is no fun.I helps to see the wideband with the fp curve to see if there is a relationship.sucks that you might have to swap out in modules and coil packs.try re gaping the plugs.
 
No, its unpredictable, it happens at random times like a misfire, but when i punch it, it powers thru. it feels like a bad maf type miss, but i put 2 known good mafs on. the fact that it only hapoens in open loop leads me to beleive its a sensor.
That's what mine did before I replaced the crank sensor. Oh I think somebody already suggested that.
 
That's what mine did before I replaced the crank sensor. Oh I think somebody already suggested that.
ok, new crank sensor same symptoms. moving on to fuel injectors and swapping out coil module for a third time.
 
Back
Top