Fuel pressure Regulator line

GrandV6

Member
Looking for OEM stock Fuel pressure regulator vacuum line. Excellent shape not beat up, cracked or worn. Would consider NOS depending on price. Thanks

Also looking for a 233 or 237 regulator
 
I have NOS 233 and 237 fpr's. message me directly for more info.
Yes, jumped on thread. Need a fuel regulator NOS Bosch 233 for my 85GN , hoping you still have one? Thanks
If he doesn’t I do.
Yes, having a issue with my fuel regulator. About 42psi from fuel pump with vac line off runs Ok, then fuel pressure drops to about 34psi with then vac line off, knock begins til I increase gas @ throttle, runs smooth at park. New with Hot Air GN , so not sure if orginal fuel reg. Going bad or I have additional problems. But if you have a known Good Fuel Reg. 233 , send me the cost. I live at area 08096 for ship costs. Thanks Mike A.
 
Yes, jumped on thread. Need a fuel regulator NOS Bosch 233 for my 85GN , hoping you still have one? Thanks

Yes, having a issue with my fuel regulator. About 42psi from fuel pump with vac line off runs Ok, then fuel pressure drops to about 34psi with then vac line off, knock begins til I increase gas @ throttle, runs smooth at park. New with Hot Air GN , so not sure if orginal fuel reg. Going bad or I have additional problems. But if you have a known Good Fuel Reg. 233 , send me the cost. I live at area 08096 for ship costs. Thanks Mike A.
I meant vac line back ON, then fuel psi drops to about 34psi & runs rough
 
In that PM, suggested he start a new thread in the hot air section rather than parts wanted section (on someone else's parts thread) for tech advice.

Bosch 237 fpr would be 42-44 psi, vac line off, engine at idle. Bosch 233 would be 36-38 psi vac line off. with vac line back on, fuel pressure will drop about 8 psi with engine at idle.

so unclear as to what fpr Grannie86 has as a 233 fpr would not yield 42 psi, vac line off. Unless it is an old Bowling Green Customs 233 fpr where fuel pressure was adjusted using an allen wrench via the vac port.

Could also be a MAF sensor problem. Parts wanted forum is not for tech troubleshooting.
 
Back
Top