Fuel pump not coming on

sams86gn

Member
Well I thought my fuel pump was bad but it turns out that it's just not getting power. I ran a jumper wire on the plug that plugs into the Fp relay with the key in the on position and it turned on. I replaced the relay and still nothing. What else could be causing this problem?
 
Bad ground maybe. Hook a test light at the 3-way connector for the tank harness. Tan should be hot, black should be ground, with key on of course. Might also check your fuses at the fuse panel.
 
Check the connection for the pump up above the tank. Mine was coroded so bad it stopped working.
 
But if that was the case then it wouldn't come on when I run a jumper wire from the harness that plugs into the relay under the hood...
 
Hmmmm...is there any way to check that? Wish I had someone in the area with a spare I could slap in for a quick test
 
It may be the ECM. There is a small transistor that provides +12 volts to the relay to activate it. The transistor tends to pop on it's own. Easy to replace it so don't toss the ECM if that is the issue.

At key-on, engine-off the ECM will power up the FP relay for two seconds. Need to key-off for at least 5 seconds before trying again.

Can check for power on pin A of the FP relay connector. It is the DK-GRN/WHT stripe wire. It is pin A1 at the ECM.

Also, make sure that the SES light turns on at key-on. If not then a fuse is blown or the fusible link at the battery is open.

RemoveBeforeFlight
 
Thanks!! I believe that was it...the wire came out of the fusible link when I lifter the wire up so it couldn't have been connected good. What size fuse is in that link or should I just get a whole new wire with the fuse in it off another car or something?
 
The fusible link wire is 20 AWG. The link is part of the battery cable. So if it too is in bad shape Casper's has new ones.

Could use a 10 AMP fuse in it's place. This is what GM did in many cars was to use an in-line fuse.

RemoveBeforeFlight
 
That fixed my problem! but now I have another problem haha. When the fuel pump comes on it sounds like air is coming from somewhere out of the tank and sounds like fuel is dripping back into the tank. I am not getting fuel at the fuel rail until the pump primes a few times and then it just runs out like it doesnt have much pressure (out of the valve when I press it down as the fuel pump is being primed). Could I have the return and feed lines reversed maybe?
 
The lines could be crossed up, but unlikely as they are each a different size.

It is possible that the rubber hose between the pump and the sending unit is split. Hot wire the pump on via the gray pigtail, remove the gas cap and listen at the filler opening. If it sounds like a water fall...

Need to use J30R10 hose for in-tank use.

RemoveBeforeFlight
 
The hose had slipped almost off the sending unit inside the tank! I would have never figured those problems out without those suggestions. Thanks for all of your inputs and especially to RmvBfrFIght for helping me figure this out!
 
That will do it. :eek: By any chance did you double clamp it?

RemoveBeforeFlight
I sure didnt! looks like I will be dropping the tank again anyway...my pump was working fine and then all of a sudden it blew the 15 amp fuse that was in the fuse panel (is it supposed to be 15 amp) and I replaced it with a 30 amp fuse because I thought it may just have been the wrong fuse to begin with and thats why it blew. Well know its not blowing the fuse but the pump just barely cuts on for like half a second. I tried to hotwire it by running a jumper wire on the plug that plugs into the fp relay and it just barely made a little noise and the wire got hot really fast. Could it be that the factory wiring is just too small? I am ordering a hotwire kit tonight anyway because I know I need it but should that fix this problem or do I have a problem somewhere else?
 
Back
Top