Fuel Pump Relay-Where?

Bobtempest

Moderator
Staff member
Joined
May 23, 2001
On my TTA the fuel pump is not cutting off after I shut the engine down. Which relay is it under the hood that I need to replace. Or what do you think is wrong.

Thanks
Rob (Bob's Son)
 
On all TTA´s the fuel pump is running about 10-15 sec after you swithched the engine off, is it this you mean?
 
relay

The relay is located on the drivers side of the vechile on the firewall. It is near the brake master cyclinder . It the one mounted the highest and closest to the strut tower. My pump shuts off when I turn the ignition off. There is a heavy red wire going into the plug.
 
its been awhile since ive tinkered on my tta,... but if you find the relay with the TAN WITH WHITE STRIPE wire attached to it, THAT is the fuel pump relay.
*note* if you add 12 volts to that wire, it turns on the fuel pump so you can drain the tank before you add race gas..
hth
 
Fuel Pump

I pulled this thread while doing a search. My car is doing the same exact thing (fuel pump running for a bit after shut-off). I don't recall it doing it earlier. Is this normal and ok? Appears to be from this thread. If this is normal why would they run the pump for a bit after shut-off???

Thanx
 
Yes fuel pump runs about 10 - 15 sec or so after turning off the ignition. Why, beats me maybe to pressurize the system so it would start easier ?
 
Originally posted by The Swede
On all TTA´s the fuel pump is running about 10-15 sec after you swithched the engine off
Hmm, mine has never done that.... The fan should be the only thing that runs a few seconds after shut down that I know of...but mine doesn't do that either after I pulled the relay.
 
Top