Getting wacky data from T-Link


Boost is good.
Jul 14, 2001
Ok here is the story. I've attached the ECM file if anyone wants to look at it. Whenever I run T-Link on my GN and go for a ride...the data will make sense in most of the frames but every once and a while you get a frame that will show BOGUS info. Examples include (this will be from one frame to the NEXT frame)

Prom ID : 4D4D, 4D4D, 9E9E, 4D4D (later on down the road something else will show up like F4F2 or something, like i am changing chips while driving!

Coolant Temp : 162, 164, 250, 163, 164 (then again later in the frames a -20 will show up or something)

Battery volts : 13.9, 13.8, 14.1, 20.5, 13.8, 13.9, 6.2??? wtf

Engine speed : 6400 rpm??? what the?

ESC Counts : 7, 7, 7, 7, 7, 14, then goes back to 7? huh?

ECM Mode : Normal, Normal, Normal, ALDL, Normal???

MAT - 130 degrees? um no!

All that "odd weird info" will all show up in ONE frame at the same coolant temp 250, battery volts 6.2, ESC count 14, ALDL mode, PROM id 9E9E (not my chip), etc. but then everything goes back to normal again...this happens every 20 frames or's like my ECM has a short in it or something?!

here's a goody...out of 249 frames recorded during one run...ONE single frame reported a malfunction code of 55 ECM A/D converter failure...WTF?! look at frame 87 and also check out frame 9

i just wonder if my ECM is going bad? i checked my cables and stuff and they are secure...what is going on here?


  • weird
    3.8 KB · Views: 67
I am having the same problem and posted it in general tech. The diagnosis is that its probably a bad ground or an ecm on its last lets. Beings almost everythign goes wacky im thinkin ecm.
Do you have another ECM or know someone who has one you can try? I would keep an eye on it and if it gets any worse rip that baby out of there.
Try this

Try unplugging the low speed fan relay, middle relay on the drivers side fender.

The stock ECM's have noise problems coming from this relay which affects:
Snap on scantool
possibly others.

I think TL is not affected, Scanmaster is fine also. But at least it's easy to


One other thing that no one mentioned, easy fix too. Did your screen saver happen to kick on while you were recording? That will give you some funny readings.

i don't even have a screen saver enabled...i will try the relay thingy...i am gonna order a new ecm anyways from that one guy for 55 bucks...good to have a spare none the less
All great suggestions ... here's a couple others that I've run across:

- Loose grounds on the back of the head

- Stereo/alarm ground back thru the harness (ground loop)

- Plug that goes into the ALDL loose/or pushed the sockets for the pins back in the connector on the car. If you CAREFULLY bend the pins in the ALDL connector you can adjust the "tightness" of the connector fit

- Laptop sitting in the passenger's side seat is bumping the parallel port connection making it wiggle (causing loose/erratic data)

- Inverter (if used) is "dirty" and causes noise thru the laptop chassis. They "hum" and ground back thru the TurboLink harness and cause data dropouts. Most are OK, but I've noticed some of the cheapest ones are really BAD.
hmmmmmmmm interesting...

maybe my ECM is not bad after all? i don't see how it could be...the thing has never been taken out of the car until last summer and never had chips swapped until then...i mean the thing is basically untouched by man from 1987 - 2001! lol and it has about 80k everyday miles on it...oh well anything is possible i guess
"Try unplugging the low speed fan relay, middle relay on the drivers side fender. "

I'll have to try this. I'm getting goofy data too with Diacom. Links fine but once you take off the data starts to get very strange unless I really am flowing 12 gm/s at WOT with 48 degrees of retard in open loop with the 4th gear switch on at 20 MPH at 50% EGR duty cycle and BLM's of 190 at a load variable of 4g/c.......
Try measuring from the ground pin (PIN A - far right side, top row) to ground with a digital multimeter. It should be 0 on the voltage meter ... I've seen some cars that get a ground loop going and you'll actually see 1-2 volts on this ... enough to skew the data pulses.
actually i did the fan relay thing and no more garbage data from the ecm...very weird something that simple could cause problems...

but the problem fan won't ever come on when i unhook that middle relay (low speed???) and my coolant temps go well over 180 as opposed to near 160 at all i plugged the fan relay back in

my chip is "supposed" to run the fan on high at all times but i don't think it there a way i can unhook the middle relay and still have the fan running on high???
Fan Relay

Here's the deal on the ran relay - datastream stuff.

The low speed fan output is actually a PWM output from the ECM, the output can't actually turn on 100%, the dutycycle goes to 99.x% or something like that. So the fan output is turning off for a few microseconds every 30 milliseconds or so.

The relay is not very well 'supressed' and generates a voltage 'kick-back' every time the signal to it is turned off.

The output chip that controls the fan relay does not tolerate the voltage kick-back spike very well and the spike bleeds over into the other channels it controls. Serial ALDL data is one of the other channels. So when the low speed fan is turned on, the spikes show up on the serial datastream and cause scantools to misread.

A couple of things to try:

1. make the fan run all the time, either by jumpering the relay contacts that feed power to the fan or by grounding the output wire from the ECM to the fan relay, This will definately work.

2. try another ECM, you may find one less sensitive to the kick-back pulses.

3. modify the relay or add a supressor diode into the circuit.

4. add filter components to the serial data line.

Anyway, #1 is the easiest. You could just ground the fan control wire (green I think) at the
ECM, this will fix it.

I hope this made things clearer,

I tried three different ECM's with no luck. I'm going to scope the ALDL line and see if there is noise or crosstalk.

I'm going to also check it with a Tech 1 and see if it's happy with the data stream.
I'm having exactly the same problem as described by Don when he started this thread. The only thing is that over time the garbage data has become more and more frequent to the point that now every other frame is bad data. If you look at the ECM link status at the bottom of the screen it is alternating between "receiving" and "idle" every other frame and I get the garbage data when it goes "idle". Does anyone have any other ideas?

I've tried 2 ECM's, 2 t-link cables, 2 laptops, and checked terminal "A" for a floating ground (it's not). I've also disconnected all of the fan relays w/o affecting the problem.


Also be sure to check terminal "A" for resistance ... if there is a marginal ground, it'll show resistance on a DVM (usually).

The other thing to look at is a slight (meaning millvolt level) voltage on the ground terminal. That indicates something may be trying to ground back through the ECM or the wiring harness (more and more common as the wiring ages in these cars, unfortunately).

As always, if anyone is having problems, don't hesitate to email me directly at:

and I will diagnosis your cable for you (and hopefully fix it, if it's the cable), if you send it with return shipping enclosed. The TurboLink cable has been remarkably robust (some of them have been in the field for almost 8-9 years now!) However, stuff breaks, wears out, gets zapped ... and we'll fix it.

The new version is coming along great and will incorporate a few "lessons" learned about isolating components from static electricity (as much as that can be done). We will have a preproduction prototype at the Nationals (maybe a couple/few, if I can put together some without burning myself too badly with the soldering iron! :D)

Stop by the GN/TType booth or Casper's booth and chat with me! I'll try to cram some repair stuff into my suitcase for the flight for on the spot repair/diagnosis...
Tech 1 and Tech 2's work like a champ. Diacom doesn't. Ground is good and the noise seems to be minimal. Certainly not enough to change the logic levels.
Tech 1s and Tech 2s ground via the Cigarette lighter, not the ALDL.

Diacom not working as well points to something in the ALDL ground (still).
Well, thanks to Ken it looks like I've identified my problem. Don't ask me why but apparently my computers operating system (Windows 95) was trying to grab the parallel port connection from Turbo-link causing it to go "idle" every other frame. When I boot directly from the T-link diskette it works fine. Ken thinks it's something in the CMOS settings (don't ask me to explain this!) that changed somehow.

Looking back at it now I think I've probably got a couple of issues compounded on top of each other but the parallel port issue was the big one. I think now that its back to normal I'll be able to diagnose the stray bad frame which could be related to a fan relay or ground issue. In any case Ken has been extremely supportive as always.