Hella H4 lights issue

sdteb

trying to get it like you
I installed the low beam hella 4x6 glass with the h4 lights...only one problem....all when on low beam all 4 lights are on...the high beams are on but a bit dim...then on high beam its brighter ...what gives?
 
I had to change the wires around on the back of the plugs, do one , (with the other disconnected)
sorry, unless I wrote it down, I ferget which way.

AND, you'll wanna improve the low beam , I went to LED's, big difference!
 
sounds like you have the LOW /HI lamp ground and the LOW/HI lamp high beam power wires reversed which is looping the LOW beam power through the LOW filament bulb then through high beam lamp even when in low mode
if you are going to run hella H4 bulbs you will also need to hotwire the low beam and high beam circuit or youll encounter an overheat of the dimmer in the car and the lamps will blink out unexpectedly
 
I had to change the wires around on the back of the plugs, do one , (with the other disconnected)
sorry, unless I wrote it down, I ferget which way.

AND, you'll wanna improve the low beam , I went to LED's, big difference!
what do you mean you had to change the wires around?
 
H4 lamps are pinned differently than the sealed beam lamps. You will need to shift the wiring on them. A relay system would definitely be in order as well, since the H4s use more current - unless you are using LED bulbs, then you're OK with the factory wiring.

Google the pinouts of H4 vs sealed-beam and you'll find the correct wiring order.
 
While looking at the plug on the car, swap the top and right terminals on the low beams. That's all.

IMG_3451.JPG
 
The Caspers hotwire kit that you referred to can be modified, swapping the pins. It's designed for the sealed beam system but can be used for the H4 if you pin it properly.
 
Back
Top