powermaster to hydroboost

the wrath

Active Member
Joined
Sep 29, 2002
i am thinking about trying to convert my car to hydroboost. i did the vacuum thing but i cannot hold boost 2 psi thats it and there is pedal fade after hitting brakes a couple of times. my powermaster was having problems with the brake light coming on everytime i press on the brake. my friend was having this problem and all she did was replace her brake pads and the light went out that was really weird .so is the hydroboost conversion a good move or not if someone has done this let me know show me any pics if u have any thanks .
 
the wrath said:
i did the vacuum thing but i cannot hold boost 2 psi thats it and there is pedal fade after hitting brakes a couple of times.

That sounds like an internal leak in the master cylinder or air in the lines.
Are the rear shoes adj correctly?.
 
I agree something else is wrong... there are alot of cars running vacuum brakes and holding much more than 2 psi... TTAs came with vacuum assist brakes and they are fine. You might want to look over your system before dropping money into another system and finding out all you had to do was ....
 
PM vs HB

I talked to several people and after searches and threads, I decided to go with vacuum. I held 9 lbs of boost last night at the track. I got my pedal from a salvage for $5 and new booster and MC from advanced for $130. HB starts at $600 from a vendor on this board (if he calls you back, wouldn't return my calls). Try adjusting your brakes to the point of having to beat the drums on with a hammer. Do you have the S10 wheel cyl.s? On track day ,for just that little extra , I took a dremel and roughed up the drums for a little extra friction. I beat a guy with a LS1 w/ 6spd and slicks :biggrin: Gotta luv a GN
 
the wrath said:
and there is pedal fade after hitting brakes a couple of times. thanks .

I will eventually convert to hydroboost. Just bought a used unit for $45. I plan on installing a seal kit on the hydroboost unit and rebuilding the mc (just for my own peace of mind). Then I just need hydraulic and brake lines.
But if you are having a pedal fade issue with vacuum, it's probably a master cylinder issue. To confirm, does the pedal fade without power assist? If so, the master cylinder is probably leaking internally or on to your vacuum assist diaphram. Separate the mc from the booster to confirm. Did you bench bleed the master before installing the unit? If not then do that.
 
Top