What does this sound like?

84GNwith87eng

Member
Joined
Jul 6, 2004
Pretty much stock motor, 30#, stock turbo/intercooler/dp, rebuilt trans...

From a stop, shifting 1-2 does not shift until I let off gas and when I do, hit about 16 degrees knock on scanmaster, when I let off gas and mash it again (when i'm in second) rpm's go flying up and knock comes back...

does it sound like a transmission problem or something with the motor?
 
trans

Hi,
Are you saying that it slips in second? I would say it's time for a rebuild, if so. Beyond that, you are certainly seeing to much knock, need to address the issue.It's hard to find gas that will allow us to see the full potential of our cars. Try a few gallons of 100 unleaded; if the ping goes away, you have the solution. Good luck!
 
trans was recently rebuilt, but the converter wasn't. Could the converter be the problem when the car is under a heavy load in 1-2 & 2-3? :confused:
 
84GNwith87eng said:
trans was recently rebuilt, but the converter wasn't. Could the converter be the problem when the car is under a heavy load in 1-2 & 2-3? :confused:

Dumb Q.
Who rebuild the transmission and is the TV cable adjusted?
 
buddy of mine, he's excellent with transmissions, been rebuilding them for years, i trust it works correctly,and its perfect when I'm easy on it, but if I jump on it, it won't shift until i let off.

forgot to mention, it has a transgo shift kit, and I'm only running 36psi fuel pressure and 16psi boost. Could that also be causing it?
 
Top