243 F- Gbodyparts alum radiator

TurboTnZ06

Go on red!
Joined
May 7, 2002
Eek- I forgot to plug in the fan. It drove fine, 183 with no fan. And I let it idle with the airconditioning on while I washed the dust off in a pressure wash bay:eek:

As soon as I saw the scanmaster say 243, I remembered I forgot to plug the fan in...

Now it is back to 173 F :D

This is a nice radiator!!!!!:cool:
 
Eek- I forgot to plug in the fan. It drove fine, 183 with no fan. And I let it idle with the airconditioning on while I washed the dust off in a pressure wash bay:eek:

As soon as I saw the scanmaster say 243, I remembered I forgot to plug the fan in...

Now it is back to 173 F :D

This is a nice radiator!!!!!:cool:

Damn how hot out was it? We were like 100* down here yesterday with 110* heat index.:eek:
 
Damn how hot out was it? We were like 100* down here yesterday with 110* heat index.:eek:

Mid 90's, heat index like 110+.

The fan wasn't plugged in. I drove it around 45 mph, no fan and it only got to 183 ish IIRC. Left it running with the a/c cranked while I dropped in $2 to pressure wash the dust off the car. It was approx 5 minutes, idling with no airflow is how it got to 243. That's pretty mean of me to do that to a car lol.

My 01 Z06, with both fans running will hit 235 in the drive through.

Once I plugged the fan in, the temps dropped below 200 quick, then to 180. Today sitting in the drive through, a/c on, it sat at 173 for a while, then barely hit 180 when I left the drivethrough, which was about 3-5 minutes.

In my T yesterday, I sat in the drive though, fan on high, a/c on, with a recored factory radiator, the temps hit 224. Nothing I could do about it.

I'm gonna get another gbody parts radiator for the T- this thing ROCKS! Highly recommended.

Good to know that in summer heat, a/c on, in 45 mph traffic I can run with no fan:biggrin:

DSC03277.jpg


DSC03420.jpg
 
Thanx for the feedback on the product...

Would be nice to see in bumper to bumper traffic temps w/ the a/c full bore.
 
In my last post, I should clarify, I have a GBP alum radiator in the GN, and a stock recore in the Turbo T, which is what I was comparing when I mentioned the T's temps yesterday.
 
Top