6776 turbo with H cover, anyone run this with the stock location intercooler?

TurboBob

Resident mad scientist
Staff member
Joined
May 24, 2001
I just installed the turbo and PTE stock location intercooler, and they don't seem to fit well together.

Has anyone run this combination?

Bob
 
Hey Bob...did you try clocking the compressor cover? is the outlet of the compressor cover hitting the neck of the intercooler?
 
Yes, I had to reclock both sides to get the turbo on. The compressor discharge sticks forward too far, causing the intercooler to be tilted, and it is misaligned left-right a little too.

To get it to fit properly, it looks like the inlet to the intercooler or the discharge from the turbo would need to be shortened, or the brackets made differently.

Perhaps I should have gotten the S cover.

Bob
 
the same words left my mouth when I installed the same turbo with a G body intercooler

Was not much fun, but it worked at the end of the day.

had to move the whole cooler forward 1/2" I had to make a bracket for the drivers side ans shim out the pass side.

it Can be done but it wasn't easy by any means,

I can post pics after Tuesday if you need them

if you are running the stock fan you have to relocate the resistor and install a piece os rubber between the shroud and fan.

good luck.

p.s. wait till you feel the power this turbo makes.
 
the same words left my mouth when I installed the same turbo with a G body intercooler

Was not much fun, but it worked at the end of the day.

had to move the whole cooler forward 1/2" I had to make a bracket for the drivers side ans shim out the pass side.

it Can be done but it wasn't easy by any means,

I can post pics after Tuesday if you need them

if you are running the stock fan you have to relocate the resistor and install a piece os rubber between the shroud and fan.

good luck.

p.s. wait till you feel the power this turbo makes.

Pics would be excellent. I am still trying to figure out what to do with this..

B
 
Car will be back Tuesday, I'll grab some pics

After all the headache, are you satisfied with the results? Or do you wish you put on an FMIC? Or perhaps I should send it in and have it converted to an S cover.......

Bob
 
I made brackets, lowered IC, tilted turbo. Nothing worked well. IC was tilted and so low I couldnt go to Walmart without hitting the speed bumps.:eek: :D

At the end of the day I cut 1 1/2 inches off the IC (PTE strectch) neck going to the turbo discharge. Fits great now. Right height and upipe fits good on TB. DOnt know if I should have done that but it works and you cant tell the difference if you didnt know I cut it.
 
I made brackets, lowered IC, tilted turbo. Nothing worked well. IC was tilted and so low I couldnt go to Walmart without hitting the speed bumps.:eek: :D

At the end of the day I cut 1 1/2 inches off the IC (PTE strectch) neck going to the turbo discharge. Fits great now. Right height and upipe fits good on TB. DOnt know if I should have done that but it works and you cant tell the difference if you didnt know I cut it.

So yours is the H cover (3" discharge to the intercooler)? Satisfied with the performance of the intercooler with this turbo?

Mine looks like it would work if I trimmed the intercooler about .75"

Post pics if you can.

Bob
 
Yes.3" outlet compressor.


Like I said...unless you pull the hose off, you cant see where I cut it so I dont think a pic will help. But I feel your pain about fighting it to make it fit.
Unless someone posts another solution get out the sawsall and cut away!:biggrin:

As far as the performance...I have been fighting a miss/pop/bad idle for 3 weeks. Only got to make a few WOT runs with new combo. :(
 
results are Amazing...feels way faster than my own car with a built engine and a front mount cooler fed by a pt70.

there is very little lag and it pulls very hard,
 

Attachments

  • 000_3004.jpg
    000_3004.jpg
    113.7 KB · Views: 191
  • 000_3005.jpg
    000_3005.jpg
    117.5 KB · Views: 208
  • 000_3006.jpg
    000_3006.jpg
    124.3 KB · Views: 192
  • 000_3007.jpg
    000_3007.jpg
    128 KB · Views: 189
I didn't cut mine. I left the driver's side bracket off, though. It's tilted, but nothing I can't live with. No ic fan on mine either. Oh and it is an H cover.
You would think PTE would have checked the fitment of both the 6776 and the PTE SS IC.:rolleyes:
 
I didn't cut mine. I left the driver's side bracket off, though. It's tilted, but nothing I can't live with. No ic fan on mine either. Oh and it is an H cover.
You would think PTE would have checked the fitment of both the 6776 and the PTE SS IC.:rolleyes:

Damon, Im glad they didnt check because you know how I like to cut and modify things on my car!;) :eek: :D
 
Mine fit fine with both brackets and no cutting. I also still run the fan without clearance problems.
 
I run the Precision 67 Qtrim with the Precision stock location intercooler & after I clocked the turbo it fit perfect? ONLY SMALL Complaint is that the pipe to TB just touches the hood insulator barely. Leaves a SMALL rub mark on the insulator. Other than that works great.

PS: The turbo-intercooler hose was Tight to get on but it wont blow off thats for sure!!
 
I had a trailer manufacturer cut mine just over 3/4 of an inch . Perfect fit and cut ..no charge and about 30 seconds of his time. I had a hard time finding someone to cut aluminium their chop saw blade was made for it as they manufacture aluminium trailers.
 
I run the Precision 67 Qtrim with the Precision stock location intercooler & after I clocked the turbo it fit perfect? ONLY SMALL Complaint is that the pipe to TB just touches the hood insulator barely. Leaves a SMALL rub mark on the insulator. Other than that works great.

PS: The turbo-intercooler hose was Tight to get on but it wont blow off thats for sure!!

I get the same rub mark! Kinda polishes the up pipe where it rubs.
 
Top