More bad news....

HOTSIX

Ran outta hand cleaner
Well, I am still sitting here on my NO START problem.

Thought it might have been my hack job with the wiring of the 87 module/coil but nope. I bought a Casper's 85 CCCI harness and put her back to original with the plug and play adapter on the end - no go. Tried the original coil / module (worked before motor re-build) - still nothing (without the adapter of course). Not even a cough of hope or a sputter.

I am giving up guys. I can't fix this problem even after finding out that my cam sensor was set incorrectly (thought that was it) im still screwed. I have tried 2 cam sensors, 2 crank sensors and 2 computers (thanks Jeremy) all with no luck. Im getting spark (got zapped:eek:) but it doesn't seem to be getting fuel. Tried test light - no flash when it's cranked over on injectors.
Is that my cam sensor or crank sensor or what....what tells the ECM to ground the injector circuit to make um squirt ?

It's going to a shop on Tuesday unless you guys can think of anything else I could try as a last ditch effort.

Thanks....
 
No problem on the ECM.....sorry to hear about your problems. Wish I could help more but this is above and beyond my experience. Good Luck

Jeremy
 
Ya...i'm sure it is plugged in right. My injector plugins are kinda stuck together...they come outta the eng. harness and plugin to the injector harness together, one on top of the other that is - kinda stacked.

My crank sensor plugs in to the new harness I wired up (the original 85 harness) replacing the 87 one I fouled up. The crank sens plugin comes outta the ignition module / coil pack.

My injectors plugin is much closer to the cam sensor on the eng. wiring harness.

This sound right ?
 
Sorry to come in on this soo late. Maybe you checked these things before. Is that a regular test light, or a noid injector test light. Where is your fuel preassure sitting when the pump shuts off when you first turn on the key? Does it hold that preassure, or does it drop in a matter of seconds? Double check all fuses and fusable links. It won't hurt to switch the injector and crank sensor harness connectors , so give it a try. It has to be something simple. Good luck. Later....Danny
 
You have spark... you have your crank sensor connection correct.

I'd look at your fuel relay. I'd get a fuel pressure guage and connect it to the rail to see if your kicking up any pressure at all.

The oil pressure switch is always suspect on these cars (gummed up internally?). This can be bypassed for test purposes.

A Caspers injector harness is always a nice item to have. Years of heat and exposure makes this item a must replace item.


Hope this helps
 
Cam and crank sensors have to be right to get spark. You can eliminate those. Is your fuel pump coming on? If not, check the FP/inj fuse. Like I said before, spray some starting fluid in the airfilter and see if it tries to start. If it does fuel is your only problem and you're pretty close to getting it running. Don't give up. It will be worth it in the end.
 
Thanks for the replies guys.

I used a regular test light for the injectors... seemed to blink slightly when I unplugged the harness from the module and supplied 12V power to "C" pin. But no blink when I cranked it.

I have 35-38 PSI of fuel when key turned fwd. Lots of gas and it holds for quite awhile after turned off..... I also have a brand new Casper's harness for the injectors - cause I thought that was the problem.


Oil pressure switch ? Will that cause a no start ? Should I try a new one first before I hit the garage with it ? You mean the entire copper looking unit that threads into the block or the plugin thats part of the engine wiring harness...?

All my fuseable links are ok and my fuses as well.

COOL 84 - I'll try some starting fluid tomorrow. I meant to try that long ago when you suggested it but it slipped my mind.
 
The injectors don't ground to turn on... They are constantly grounded on one of the 2 pins. This ground is run through the injector harness and if I remember right it grounds to the block near the A/C compressor. There are a few other ground wires that connect to that same bolt. One of those grounds could have possibly slipped through the crack in assembly, or broken the connector somehow...

Things to rule out:

Coil pack/module, Crank sensor (since you have spark)
Fuel pump, Oil press. switch, fuel pump relay (since you have fuel pressure)

I'd bet that ground wire is screwed up somehow. Forgive this if you've already checked that... :rolleyes:
 
I'm pretty sure the computer triggers the injectors with the ground. With my key on, engine off if I ground one end of the test light and put the other end in the injector plug it will light. If I put one end of the light on the positive battery terminal it doesn't light. I know one of those ground wires is for the injectors. Mine broke a while back and caused a no start.

I assume you've tried the starting fluid already?
 
I had the same problem last year. I found out the IAC was bad. try and unplug it, see if the car will start. I gave up too took the car to the shop and they unplug the IAC told me to come and pick it up, after I took the car home I was looking around and saw the IAC unpluged. pluged it in no start! unpluged it and it started! changed the IAC never had another prolblem. I found out the hard way $350.00 later for nothing! working on this car with out a scantool Is working blind, I have had to come to that descison the hard way too. but your problem is something small and its right there but, you will not see it because you are getting frustraed take a time out. I am sure you will find the problem. get back to the borad with your progress. I know its hard. Stop and take a look at the car not just under the hood and you will feel better, it worked for me.
 
Cool84, I'm confused why anyone would want to use starting fluid on their turbo Buick. There isn't a turbo V6 out there that needs starting fluid to start. If it won't start, there's a problem with it.

How will it help?

How about really dumb stuff like:

Improper alignment of cam/crank gears
Improperly ground camshaft
Loose ground wires
Improperly burned chip

I'll think of some more, but that stuff comes to mind first after eliminating oil press. switch, cam and crank sensors...

Does it give an SES light?

Does it try to start? ie: hit's a cylinder then misses 5 etc... Or does it just crank with no hope of starting?
 
Sorry guys...

been tied up for awhile....

I took it to the shop. Snap On scantool says TPS volts 4.XX at key on....TPS bad I guess.
New one put in today - still same old NO START...rolls over and over with no hope of a sputter.
Injectors work now though...I guess ECM shuts off inj if WOT TPS volts shows huh ?

So it is getting gas...spark (lots)...and has good compression...

WTF ??????

I'm gonna call him to try that IAC unplug trick !!!! Thanks...
Let ya know tomorrow......he's getting frustrated too......

This is brutal guys...gone on wayyy too long.

P.S. GM has discontinued the TPS's for our cars....I got the last one on a GM dealer's shelf !
 
You did recheck the TPS voltage after you installed the new one, right? If it somehow lost it's ground (ground wire not hooked up)the voltage would go to reference voltage which is around 5v.

I said improperly installed cam a long time ago and I have no idea if he checked that. The reason for spraying starting fluid is because there was so much confusion as to whether or not he was getting fuel. There was much disagreement on the testing procedure so I said to just spray some starting fluid in there and if it tries to start you know it isn't getting fuel. I said that just to eliminate the fuel question.

Things we've already covered in another thread include: Does it even try to start, SES light, chip, grounds, cam installation, cam and crank sensors (which have been eliminated). I was leaning more toward cam timing but I'm really curious if it's getting fuel or not first.

Usually if it's getting spark AND FUEL it will do something like pop, backfire, smoke, or give some sign of life even if the cam or whatever else is out of whack.
 
I guess ECM shuts off inj if WOT TPS volts shows huh
Yea, this activates the 'clear flood' field in the ecm, which does what it sounds like, clears a flood condition by stopping the injectors.

Good luck man... you sound sooo close. I just had my engine out, I put a new one in pretty much blindly (with just the engine assembly manual) and it started first crank. Sounds like I got super lucky.

Dave
 
Thinking out loud here...

HOTSIX tells us that the engine has good compression. Cool84 points out that an engine would try to start or cough and sputter even if the cam was ground improperly and/or installed improperly. I agree.

I guess that would tend to rule out a bad or improperly installed camshaft.

The only other thing that I would say to try as it relates to the camshaft is this:

Take the cap off the cam sensor and have someone crank the engine over while you watch the cam sensor. The interruptor ring should spin while cranking. If it does spin, this will tell you if the timing chain is working properly. If not, then you've got a broken timing chain, or didn't install the bolts on the cam gear, or the woodruff key in the crank shaft.

This *could* cause the condition that is happening. If there is no oil pumped up into the lifters, then the valves are barely open on some cylinders if at all. This would give good compression readings and would not allow enough fuel to pass into the cylinder to fire.

The only catch with this is the cam sensor setting. If the cam isn't spinning in the block, then how do we get spark? If the cam sensor is still set at the recommended settings, but the crank spins, will we get spark? I don't know and my brain hurts trying to think about it! :rolleyes:

The same could be accomplished by pulling a valve cover too, but I figured the cam sensor cap was the easiest.

As I'm typing this, I found another catch to this theory... If you have oil pressure, then the camshaft is spinning. Since the oil pump connects to the cam sensor. Still might be worth trying.

When you start it, are you giving a little throttle? If so, then you can rule out IAC. If you're not giving it throttle, then IAC could be a problem.

This is a wierd one... There has to be an answer though.
 
I seemed to have the same problem. spark and fuel pressuer but the injectors would not fire. Mine turned out to be the IAC I sprayed starting fluid and pumped the gas pedal anything I could think of nothing. he could have a ground problem and even a crank sensor. so let see what happens next.
 
Well guys...

cool 84 - I suggested starting fluid to my mechanic - he says no way on a new engine. Had the noid light on the injector (#1) and it was flashing on eng crank upon installing the new TPS.

The TPS volts were NOT checked upon re-installation 'cause I watched the other guy from the shop put it on and then go turn the key. Could this cause a problem ? I also tried the IAC unplug trick - no luck there either.

A pal of the mechanic's at a GM dealer tried to get the GM service manual but none there for my car. GM mechanic says "GOOD LUCK" sarcastically to him. Says maybe try the mass air sensor - said if it's broke then it wont start ???? This true ??? How do you tell if it's screwed...scanner volts show up for it ? If so...what's good and bad ???

I checked if the cam sensor was spinning on cranking the eng. - and it was. So it seems no problem there. Plus I got a brand new chain in it as well as the cam. Maybe cam installed wrong - but I doubt it. Really good shop did the engine and thousands more but I suppose mistakes can be made. Cam tool from Caspers might help ? I think the cam sens is set correctly (now thanks to RED) but cam tool is error free pretty much...or idiot proof.

So still no codes / SES light, no sputter or attempt to run and I have a spare ECM (thanks again nocooler) with a ATR Pitbull chip in it and my orig. PROM in it also. ATR chip and my cam causing a problem - should I try the orig chip again ?

Would it spark and inject if cam and/or crank sensors were off ????

I have been playing with this problem in my head every day and a few things poped up:

1. OLD (like at least 1 and 1/2 yrs) gas in tank
2. Plugs....AC CR44TS (or somethin like that...has 44 in it)...are they the right ones ?
3. When I resoldered the new original CCCI module harness from Caspers on to the engine wiring harness I MAY have reversed the two pink / blk wires from their orig spots. ie: there are two spots for them and I might have mixed them up. I think they are the last one and third last one...problem here ??

Again guys I appreciate all of your help and interest.

Jon
 
I'd check the wiring. Starting fluid won't hurt anything (except on a diesel motor). Just try it. If the car sputters or backfires or shows some sign of life then you know you have a fuel problem. Your gas is pretty old too. Did you add a stabilizer? Again, even if the gas is too old, starting fluid will make it at least do something. If not, then you have other problems.
 
Back
Top