Turbo inlet hose keeps coming off

blipmode188

Member
Joined
Jun 28, 2007
I am having a problem with my turbo inlet hose coming off ? I have a 3" S.S. inlet air supply going through an LS-1 maf and a cone air filter.

The last couple of times I drove the car and jumped on it a bit to wake up the turbo, a few minutes later the car would barely run and when
I pulled over and checked the air inlet hose to the turbo had come off the turbo.

I have a rubber transition piece clamped to both the turbo and the S.S. inlet tube and they have been tightened as tight as they can be.

Is it possible I am getting back pressure from the turbo and blowing it off ?
Thanks Steve
 

Attachments

  • DSC_1811.JPG
    6.7 MB · Views: 49
Thank you for the info.
I’m going to replace them with the t-bolt clamps. Hopefully that will fix it.
Steve
 
Air inlet hose to turbo inlet normally does not blow off unless it pulled off from a bad motor mount on the drivers side or something. The only ones that blow off or come apart are the hoses from the IC to throttlebody and sometimes from turbo to IC.
 
Last edited:
^^^ What Joe said , with a bad motor mount the motor torques over and the inlet pipe hangs up on the up-pipe to the throttle body pulling it off the turbo .
Get T-bolt clamps , they are stronger and easier to work with .
 
Sounds like new turbo hose, clamps and I will have both motor mounts replaced. My guess is they both could use replacing anyway.
Thanks for the help Steve
 
Sounds like new turbo hose, clamps and I will have both motor mounts replaced. My guess is they both could use replacing anyway.
Thanks for the help Steve
Not a complicated job at all to do at home.

Loosen mount bolts, wood in between oil pan & floor jack, jack motor up, remove old mounts, install new mounts(HR if not going stock), & lower motor back in place.

For me the hardest part was the HR mount hardware with the engine still in car. Went through wheel wells, various extensions and swivels, and done!

An easy weekend job & honestly won’t even take you that long.
 
Sounds like new turbo hose, clamps and I will have both motor mounts replaced. My guess is they both could use replacing anyway.
Thanks for the help Steve
Do your best to find some original mounts. The aftermarket replacements are crap and the poly mounts are to rigid. Also, add an RJC brace so the stress is taken off of the mount. It's the best way to keep the engine from rotating.
 
Top