Cold Air Intake setup issue

trixdout

Active Member
Joined
Sep 4, 2012
So guys I really searched on this forum, this time (unlike the other threads I've started), and cannot seem to find anyone running this 3" cold air intake from gn1performance (http://gn1performance.com/proddetail.asp?prod=ColdAirKit).

I'm having a fitment issue where once I get the pipe that has the 90 degree bend doing behind the headlight goes down, it does not line up with the maf pipe at all. It's off by about 2 inches. Do I need an offset there? Or should the pipe line up correctly. I also installed the KB headers (3bolt), is that a reason why my cai does not line up properly?

I also did not move the vapor canister at all. Do I need to move that or can it stay in place?
 
It will fit. Takes a few minutes and a lot of deep breathes. Where it mounts to the core support, bend it a little and it should fit perfectly. Mine Did!
 
It will fit. Takes a few minutes and a lot of deep breathes. Where it mounts to the core support, bend it a little and it should fit perfectly. Mine Did!

Core support? I'm not that great with naming things by their proper name, but once I learn them I don't forget. You mean the sheet metal behind the headlights, where the pipe goes through?
 
It is for a 3" MAF. Your stock will work if you have reducers, but will be funny looking, waste of money n performance.
 
I'm taking a wild guess that the stock maf won't work with this setup?

You might want to give a call GN1 Performance and ask them which one you order since it did claimed to "please specify which mas airflow sensor you are running".
 
You might want to give a call GN1 Performance and ask them which one you order since it did claimed to "please specify which mas airflow sensor you are running".

Funny thing is I did specify, but the box came with no instructions or anything of the sort. I'm not dim witted, but I told them that I was going to use the stock maf at first then switch over to the 3" lt1 maf sensor I have once I get the money for a translator.
It is for a 3" MAF. Your stock will work if you have reducers, but will be funny looking, waste of money n performance.
Performance wasn't really an issue because it wouldn't be permanent. And yea it did look funny when I was putting it together that way. Oh well.
 
Funny thing is I did specify, but the box came with no instructions or anything of the sort. I'm not dim witted, but I told them that I was going to use the stock maf at first then switch over to the 3" lt1 maf sensor I have once I get the money for a translator.

Performance wasn't really an issue because it wouldn't be permanent. And yea it did look funny when I was putting it together that way. Oh well.

I'm not insulting you, but it might be that someone could have gave you the wrong set up? Just a thought
 
I'm not insulting you, but it might be that someone could have gave you the wrong set up? Just a thought

Oh no, I know you weren't insulting me. I didn't take it the wrong way. It is very possible they could have.
 
Top