installed gbody slic/ now getting code 34

buickbert

Member
Joined
May 15, 2005
just like the title says, i installed the gbody slic the other day. the first time that i "got on it" i got code 34/ maf failure. i unplugged the maf and made sure it was clean. unplugged the ecm to reset the codes. drove the car once sunday (around 9 miles) and to work and back today (3 miles) and didnt have a problem. i just got back from the store and on the way home the ses light came on again code 34. reset the computer again and now it comes back on within 10 seconds of strating it up.

this is a remand maf, BUT i have been using it with no problems for the past 5 months, is this the life span of a remand maf or

does this have ANYTHING to do with the new ic?

buickbert
 
what is your MAF count at idle?
Do a tap test on the maf.
ALso check all IC connections
 
ill have to check the maf counts in the morning, that the "af" on the scanmaster right?

also, whats the "tap test"?

and by "ic connections" thats the hose connections correct?

buickbert
 
ill have to check the maf counts in the morning, that the "af" on the scanmaster right?

also, whats the "tap test"?

and by "ic connections" thats the hose connections correct?

buickbert


Dunno about the first question, but the tap test is where you take a screwdriver and tap the MAF while the car is idling. If the idle changes, i'd suspect the MAF.

Correct on the connections, meaning the hoses.
 
Most of those rebuilt mafs are junk and not calibrated right for a turbo buick, I had 2 of them rebuilt stock mafs crap out on me within a couple months of each other, thats when I went the translator route.
 
If you don't mind can you check or even post a pic of the pitman arm to IC clearence with the wheel turned to the right about 3/4 turn. I don't have brian's IC but I have a copy cat and I am having issues with it. Thanks:)
 
Most of those rebuilt mafs are junk and not calibrated right for a turbo buick, I had 2 of them rebuilt stock mafs crap out on me within a couple months of each other, thats when I went the translator route.

X2. If you have a local GN buddy see if you can swap over a known good MAF. I do not trust the aftermarket MAFs either.
 
well i got in the car this morning to go to work, as soon as i pulled out of the driveway the ses light turned off. this is starting to annoy me.:mad:

buickbert
 
Top