Need help hooking the wideband to my Gen 2


Active Member
I just installed an AEM wideband in the car. I ran the wires from the gauge to the Gen 2 (white from gauge to orange on gen 2 and ground from gauge to purple on gen 2) and on the maiden voyage (under no boost and low RPM) it went so lean that the car stalled. The reading on the gauge was _ _ _ because it was outside the scale. In the settings for the Gen 2 I chose the 0-5v AEM gauge and used these settings:

min tps = 3.0
min rpm = 3200
min load = 166.4
lean lim % = 10.0
rich lim % = 25.0
gain = 12.0
afr = 10.8 from 2000-8000 RPM
aux % = 0.0
aftr delay = 0.3

Never got a chance to see how much fuel was being pulled out... Unhooked the gauge and it runs as before (AFR =14.5 cruising and very rich >10.0 at WOT) Suggestions on what is wrong? Thanks.
What version is your GEN2? I had an earlier version that did the same thing when I hooked up my wideband to it. I had a newer version that worked fine.
The manual????? What does the GenII say on the screen when you power it up??
disconnect the orange and purple wires from the ecm harness and connect them only to the wideband. It sounds like the wideband is feeding the ecm and Gen2 at the same time.

So I unhooked the orange and purple wire connections to the ECM and it seems to be working great. I haven't been able to take it for a spin yet but the idle was dead on and the AFR on the wideband matched the gen 2 perfectly. Thanks Bob!