To MSD or not to MSD?

disco stu

Active Member
Joined
Apr 10, 2002
Now that I have a brake, i would really like a 2 step. It would be much easier than trying to watch my boost and RPMs as the tree comes down. A hotter spark than even the stock ignition provides and a wider gap would no tbe so bad either.

However, there has been a history of problems associated with this when used with FAST. I am using an XFI BTW.

I called MSD and was told that this is not an issue anymore.
 
Now that I have the DIS4 with 2 step, I cant race without it. I did have one box fail 5 weeks after I bought it, so I HIGHLY recommend ordering yours from Summit. The day after it took a crap, I ordered another one from Summit so that I would have it 2 days later. Then I shipped my old one back and they credited me the full amount AND the 8.95 handling charge, no questions asked. The box carries a 1 year warranty so buy new and save your reciept.
 
Ahh, a reply. ;)

Thanks SPOT. Did you get an HO or non HO unit? And also, any noticable difference? Are you running more gap?
 
disco stu said:
Ahh, a reply. ;)

Thanks SPOT. Did you get an HO or non HO unit? And also, any noticable difference? Are you running more gap?
I got the non HO unit and run my gap at .040 with autolite 23's and over 30psi :D without a single miss. I like the ability of the MSD to control my rev limiter too.
 
im installing one now. i have a used unit i got from duttwiler. does it need to be rubber mounted? i was thinking of installing it inside the driver compartment under the dash. whata you think? thanks. Len
 
get the extended warranty plan, save you in the end......my ignition testing thread has vanished :confused:
 
norbs said:
get the extended warranty plan, save you in the end......my ignition testing thread has vanished :confused:
norbs---how did you mount yours? is it a good idea to keep it out of the engine bay?
got any photos? thanks
 
:cool:
 

Attachments

  • MVC-217S.JPG
    MVC-217S.JPG
    38.2 KB · Views: 184
  • MVC-219S.JPG
    MVC-219S.JPG
    37.7 KB · Views: 165
I run 3 accel boxes instead, more involved and heavy but, i rather stay away from the MSD stuff for now.
 

Attachments

  • 300box.jpg
    300box.jpg
    82.8 KB · Views: 324
So I take it that the HO version won't stand up if the car sees any amount of street?

And does anybody know how the spark energy of a CD ignition compares to the spark energy of a stock inductive ignition?
 
norbs said:
I run 3 accel boxes instead, more involved and heavy but, i rather stay away from the MSD stuff for now.
Norbs, can you put together a step by step How-To to put the tri Accell box system together? I know I'd like to use it with my remote mount Type II system.

Thanks,
 
well i got this msd installed. got power from the battery and the 2 red wires have 12 volts with the key on. the red led light blinks. the dip switch is set to waste spark and the timming switch is off. and i get no spark. but it runs with the by pass installed. WTF??? its a used box i got from kenny a while back and this is the first time i tryed to use it. i guess the box could be bad?
 
also the red light blinks with the key on and blinks a little faster when cranking the engine over.
 
Send it back, probably only cost you $100 to fix.


clx...........its very simple buy the 3 adapter connectors from MSD summit raing $20 each. Each section of the module gets ground from the white wire on each 300 box. The coil +,- connects to the outputs from eaqh accel box. The other wire that used to feed +12v to each coil you can just cap it, or use it to trigger a relay and make a hot wire kit off the alt to feed the 3 igition boxes. The boxes go from 70-100 each on ebay, so yes it is expensive and the output is Less than the new MSD HO box, but more than the non ho box. You can thank BRuce for helping me on this setup. The car does drive quite well, over the stock setup, well enough to melt the valves out of it!
 
norbs said:
Send it back, probably only cost you $100 to fix.
do they still fix the older box's with dip switch's? have you ever had one repaired for that price? i called msd and they told me i didnt have enough power. then said i had the adpter wired wrong. both are correct and i switched the adpter and cable as i have 2. the light blinks as i turn over the car and then blinks every 1 sec. msd says that means the box see's a problem.
 
Top