Did I install this cam sensor correct?

87WE4!!

Active Member
Jul 2, 2018
173
50
28
Have you verified fuel pressure?


Sent from my iPhone using Tapatalk
No, I have the stock one in right now. I have a Kirban’s adjustable fpr that I’m gunna install as soon as my fuel rail gauge adapter comes in the mail. I have a gauge but nobody local sells the rail mount.
But the stock one is on at the moment.
 

87WE4!!

Active Member
Jul 2, 2018
173
50
28
Car will start without gauges. Check engine verified power to ECM. The alternator will not charge without the idiot light or a resistor connected.


Sent from my iPhone using Tapatalk
I didn’t even install the alternator yet. Well I did at first but I removed it to free up space till I can get it running. But I keep the battery 100% charged. I have 11v at the battery as the starter is cranking.
 

ScottHeidinger

Active Member
May 2, 2015
684
116
43
50
northeast Florida
You can buy a cheap fuel pressure gauge ($30) that will connect to the fuel rail for testing at any auto parts store. Just need to make sure you have 35-40 psi at startup. If the IGN and ECM fuses are good then check your connection at the ign module for bent, broken or missing pins. Do you still have another WE4? If so then I would try swapping the ign module/coil pack for testing


Sent from my iPhone using Tapatalk
 

87WE4!!

Active Member
Jul 2, 2018
173
50
28
You can buy a cheap fuel pressure gauge ($30) that will connect to the fuel rail for testing at any auto parts store. Just need to make sure you have 35-40 psi at startup. If the IGN and ECM fuses are good then check your connection at the ign module for bent, broken or missing pins. Do you still have another WE4? If so then I would try swapping the ign module/coil pack for testing


Sent from my iPhone using Tapatalk
I do own another WE4 that my mom lent me the money for and helped me buy when I was 17 and very disrespectful to her and running with a bad crowd back when I lived in Brooklyn. Honestly the day I got that car I changed my life. Unfortunately my mom passed away before I could really make peace with her. So that car means the world to me and I don’t have it in me to pull parts off it. It’s something about that car. Sorry for the story, I just wanted to paint a picture why.
But I can buy an ignition module at AutoZone tomorrow. And my ecu is always covered under warranty so I can always go swap it out for another one.

As far as the fuel pressure goes I’ll pick up a fuel pressure tool at harbor freight tomorrow and I’ll hook up the Kirban FPR and set it at 40psi.

Is there any pins at the ignition module harness I should check for standing voltage?

Thank you for your help!!
 

earlbrown

runs with scissors
May 26, 2001
7,110
1,299
113
48
lagrange, GA
Be careful on your bike. I had a 2010 bmw s1000rr and someone made the left in front of me. Long story short I have dissolved screws in my hip. But I never learned. I bought a new 2014 bmw s1000rr. And I just bought a 2016 Kawasaki Ninja H2 last year that was dropped and Is rebuildable salvage. I love that bike. It’s the unicorn.

I've still got 10 bikes but I haven't rode any of them in about 5 or 6 years. 14 years of pro roadracing did a pretty good job teaching me how to dodge cars... ....still didn't stop a station wagon from T-boning my left foot in the rain and knocking me off the road at over 120 though. Pretty impressive how I didn't crash and land on the underpass I was heading towards.


On your car, you have a no spark situation, so ignore quite a few of the last posts about fuel pressure. Odds are your plugs are soaked anyway from repeated attempts at cranking.

Someone earlier posted the 'no start tree' on vortex-buicks. Find that chart and go though it systematically. You'll find the problem. It'd be nice if you have known good parts to aid in troubleshooting (much like how to troubleshoot an IGN box on a bike/ATV- ''if everything else passes, replace the ign box'').

Making these cars run 'perfect' can be a trick, but making them bust off and run is pretty simple.

I'm starting to wonder if your coil pack picked right now to take a crap on you. If you get bored, remove the torx screws holding the coil pack to the module and see if the potting material has turned to jelly. Also, that bolt that holds the plug to the module, back it off 1/8 turn so the contacts can float enough to find their happy place.

There's one big caveat working on these cars that do not cross over on your bike experience... 'New' DOES NOT mean 'working'. There's been many many many people over the years go down the wrong rabbit hole by shotgunning working parts and having two (or more) bad items.

There are a whole lot of parts on these cars where you'd rather have tested/good GM over new Chinese any day.
 

ScottHeidinger

Active Member
May 2, 2015
684
116
43
50
northeast Florida
I get that you don’t want to remove parts from the other car but you can spend $1k in parts real easy and still not figure out what the problem is. These cars often have corroded connections, ground issues and bad fuseable links in addition to failed parts. Having know good working parts to swap out and troubleshoot can save you a lot of money. Some of the brand new coil packs and modules that they sell at stores are often no good either. Following the tree knowing that you have injector pulse the next things are the ECM SOL fuse and ECM ign fuses followed by the module. I suggested swapping the coil pack and module together because it only takes 1 bolt and two nuts to remove the entire assembly and swap a known good one for testing. There is a epoxy on the top of the module that goes bad runs out the side of the module. This can allow things to short out in the module once the epoxy is gone or can allow the coil pack to short out. You could separate the coil pack from module to see if the epoxy has turned to goo and see if there are any signs of arcing. Here is the no start tree you can use. I’m sure you have a meter to work thru it.

http://www.vortexbuicks-etc.com/no_start_tree.htm




Sent from my iPhone using Tapatalk
 

ScottHeidinger

Active Member
May 2, 2015
684
116
43
50
northeast Florida
The shorted injector could have damaged the ECM. I have not been able to locate the 30# injectors that I have but I do have a set of stock injectors that were replaced many years ago with bigger ones. You are welcome to have the stock injectors if you want them. I wouldn’t recommend keeping them for long with the available options out today but they should be fine to get your car up and running. One is missing the orange end but they are free if you want them.


Sent from my iPhone using Tapatalk
 

michael evans

Active Member
Feb 27, 2008
847
81
28
Louisville, Kentucky
I will never troubleshoot with a volt meter again on my car. I pulled my hair out running in circles It almost came to just pouring a can of gas on it and walking away.
After spending over $1K on it and many hours. I got out the load light I made in The Air Force and started over with the troubleshooting. I found the problem right away.

I had to replace the engine wiring harness which was cut up anyway.

Engine started right up.

I didn’t even install the alternator yet. Well I did at first but I removed it to free up space till I can get it running. But I keep the battery 100% charged. I have 11v at the battery as the starter is cranking.
I have found that the car will not start if the computer does not see 12 volts at the orange wire (battery) with the key on.
 

raregn

Addicted to BOOST
Jul 20, 2010
82
14
8
Winnipeg, Mb. Canada
You didn't plug the fuel pump test wire into the tach test wire did you?
They are right behind and kinda below the alternator. They look like they should be connected, and they will plug right into each other but they shouldn't be. I don't remember if that will cause a no start but it's a simple thing to check.
 

NorCalTurbos

Slowing down to SPEED UP!!!
Nov 9, 2013
1,067
41
48
37
Bay Area California
Sounds like the cam sensor is 180' out, mixed with some major vacuum leaks where you said there is no PCV valve in it yet.
It will start 180' out, but it sounds like the battery is dead.
Set the engine to #1 TDC compression and put the cam sensor in like in the picture, no test lights multi-meters or other tools needed . That's how the factory did it when they built the cars. The factory lined up the tabs, I have found this to be exactly 25' after TDC. At least it is with a new timing chain.
I've set them both lined up perfectly and as in the picture and there is absolutely no difference in how the car runs.

View attachment 335723
X2 mine did the exact same thing but when it finally ran 180 out it blew raw fuel on my garage wall straight out the pipes and I ended up with fuel in my oil, SMELL the dipstick.
 

earlbrown

runs with scissors
May 26, 2001
7,110
1,299
113
48
lagrange, GA
You didn't plug the fuel pump test wire into the tach test wire did you?
They are right behind and kinda below the alternator. They look like they should be connected, and they will plug right into each other but they shouldn't be. I don't remember if that will cause a no start but it's a simple thing to check.

It won't. It'll just cause the boost/tach module to malfunction until they're unplugged.
 

87WE4!!

Active Member
Jul 2, 2018
173
50
28
You didn't plug the fuel pump test wire into the tach test wire did you?
They are right behind and kinda below the alternator. They look like they should be connected, and they will plug right into each other but they shouldn't be. I don't remember if that will cause a no start but it's a simple thing to check.
No I know then apart. But thank you for the input
 

87WE4!!

Active Member
Jul 2, 2018
173
50
28
Sorry for the late update.
I rented a fuel pressure tester from autozone. Because I still don’t have a fuel rail adapter for my own fuel pressure gauge.
Anyway, when the ignition primes the fuel rail the fuel pressure climbs to 7psi. When I put power to the fuel pump the fuel pressure will rise to 40 (where my Kirban FPR is set to). But as soon as I remove power from the fuel pump all the pressure is gone in 10 seconds. This leads me to think I have a leaking injector. Hence the spark plug stinking of gas on the #2 injector that won’t even click when I test it with power.
Thanks to the generosity of Scott up here he has sent me a set of injectors and a chip that I’m 90% sure will solve my problem. And if it doesn’t he offer to drive 3 hours to me to help me. How bout that guy. Everyone on this forum has been awesome to me.
I started sanding the body until the injectors come in the mail. Figured ide keep busy until I get sick again. Lol.
 

87WE4!!

Active Member
Jul 2, 2018
173
50
28
Hi Guys/Ladies out there,
No update yet unfortunately. As soon as this car fires my TurboBuick forum family will be the first to see the startup video. But I just felt the need to share something completely off this topic.
So, as most of you already know from especially if you read my new member introduction to this wonderful forum y’all know that when I was 17 growing up in Brooklyn ny angry that my dad was taken from me when I was 9 that my mom lent me all the cash I needed to buy my very first car which happens to also be a 1987 Buick Trubo T WE4 (which I consider myself blessed because on February 22 1987 on my bday my mom and I drove to literally every dealership looking for a new or very low miles cold air Grand National and everywhere we went all we got was a “sorry all turbocharged Buick regals are sold out and we are no longer taking pre orders”. And of course everyone (salesmen) was trying to talk me into a black Buick Regal which was absolutely beautiful but not what I was looking for. Fortunately my mom was smart enough to leave our phone number. And I think she also told most of the managers at the dealers about how my dad was taken away from me as a child from brain cancer. And how she works 2 full time jobs since my dad!s passing and how I was the only Italian boy growing up in Brownsville Brooklyn ny in the 70s/80s (I’m just gunna go out and say it. This was a 99% African American neighborhood and I was odd ball. Now as a child with my mom working 2 jobs to support us and save something my mom’s best friend got us into an apartment in Brownsville not long after my dad died and the money ran out. Mom’s friends also babysat me after school, Fed me, her sons were/still like my brothers, helped me with my homework, Etc. Everyday of the week till after 11pm when my mom got home and picked me up). Now, the reason why I explained everything above about my childhood is because one year when I was taking my FDNY annual medical and diversity training I wanna say it was around 1995ish we watched a video and one of the things that I learned is saying “I have black friends” or words to that effect is actually a racist thing to say. But in my case it was the truth. All my life African Americans have helped me and My family more then anyone in my bloodline family (no help from aunts, uncles, cousins, nobody). And my mom’s best friend absolutely refused to take a single dollar for helping us (she was an older woman and loved helping us and never threw in in our face). But the truth of the matter is that I literally had no childhood due to the violent crimes I wasn’t even allowed to go outside and shoot hoops in the courtyard. It was literally school and home (well home to mom’s friend’s home). But when I was 15 I started running with a bag bunch of guys who have all either passed away or are incarcerated for choices they made after my mom lent me the money to buy my car.
Sorry for the long story above. But years later I found out that my mom told all of the dealership managers about my history how all I really cared about was that Grand National. So literally 3 days later we got a call from a Buick dealership in Garden city/Hempstead on February 25 1987 we were asked My I think it was called Garden Buick (I need to look at my window sticker to verify). Anyway the lady said it’s not a Grand National it’s a WE4 to which myself of anyone working there had any idea what that meant. The turbo regal expert salesman was off that day. But 10 seconds after looking at it I knew this was gunna be my car. It was the most beautiful machine I’ve ever seen. I had my car.
Ok so now my mom lent me this money to buy the car outright, no liens, no paperwork, no promissory note, no interest, nothing. Her only requirement was not to drop out of high school. But we had one more problem. I just turned 17 and even tho I had my full drivers license you have to be 18 to purchase a car from a dealership. So my mom had to go on the bill of sale as a co buyer even tho we were paying cash outright, but the lady Doing my paperwork attempted to title it in my name anyway. And it actually worked. I’m guessing because my dad and I share the exact same name on our DL when he was alive I guess nys dmv didn’t have the computers and data that have today to verify everything I guess nys dmv thought he bought a new car and titled it to him. Either way the title was solely in my name only. So I’m pretty sure I’m the youngest original owner of one of our cars.
Once again I apologize for the long story. I woke up and can’t sleep.
Now I never drive this other car because this car changed my life. It tought me to grow the hell up and stop feeling sorry for myself because of my dad’s passing. It made me a responsible person because even tho it was a loan from mommy. I got a job at the supermarket that next week and I treated that loan like it was a car note. As I got older and moved into my own apartment I made sure that car payment was made even before my rent was paid. Finally making my last payment in 1992. Even tho my mom long since forgave me for the years of disrespect and was very proud of me. I lost her in 1997 at 56 to a heart attack. To which I never got the chance to say goodbye and how sorry I was.
So once again I’m so sorry for the long novel. When my mom passed I literally couldn’t drive it anymore. I’m 1997 I parked it in my sister’s garage in Long Island and never looked at it again till 2018 when my sister retired and sold her home moving to Florida and shipped it to me. I really didn’t want to see it but I wasn’t ever about to sell it. So I replaced everything fuel related from the tank to the fuel lines. And all the fluids. Car started and ran like new. Sometimes when I drive this car I feel so blessed and like my mom is riding shotgun. And I can sometimes hear her “slowdown” she always said. And sometimes there are days when driving it makes me sad. Well I took it out yesterday for it’s weekl 20 mile drive to keep it healthy. And I had such a great feeling while driving it.
I just awoke from a dream about both my mom and dad which I never had in 49 years. It was almost like an everything is gunna be alright dream. Because my future is kinda scary for me. I have serious breathing and heart issues from breathing that toxic $h!t at the World Trade Center collapse (remember the incident that our wonderful mayor of nyc said the air quality was safe??? Well let me be the first to tell you that everytime I log into my Facebook I see another friend passes away from wtc related illness which is why I deleted my FB account. Truth be told I’m scared shit about what is gunna happen to me and who will take care of my wife). But anyway I finally got the dream that everyone who looses their parents wants to have.
Yes, lol I know the question you’re thinking. What’s his point? My dad who was a police officer and a shop mechanic spoke to me in this dream. He told me that in addition to installing the injectors that Scott shipped to me that I should Have tomorrow. He told me not to start it until I put everything back together, the new radiator hoses, top off the coolant, alternator, belt, compressor, air filter, put the whole engine back together before trying to start it again after installing Scott’s injectors and chip. What he said in the dream made a lot of sense because what if I put the good injectors in and she starts up. I can’t let it run for the 20 minute cam break in with the break in oil without coolant in the cooling system.
Even if the whole thing wasn’t real and it was just my mind trying to cope with my ptsd. It still made me feel really excited about getting the injectors tomorrow and literally gave me the emotional support to continue and complete this project. And I just needed to share with my TB family.
Sorry for the off the topic post but it’s 0330 in the morning and I literally can’t sleep. I’m literally watching the sopranos and writing about this dream that I just woke up from. That I was told everyone who looses their parents has once in they life where their departed parents come to them usually at the most stressful point in their life and literally tell them how everything is going to be alright in the softest and most convincing voice. Between my post 911 fdny ptsd, living right next to Daytona airport, and my declining respiratory issues this was something that I really needed to experience. And it started yesterday afternoon when I took the car for a ride.

Guys I think it’s gonna start tomorrow. And even if it doesn’t. I’m not gunna give up on it.

Thank you for reading through all of the above. I swear it’s all true.
God bless all of you
Goodnight
 

87WE4!!

Active Member
Jul 2, 2018
173
50
28
So I got the 30lb injectors and tt chip in the Mail. I installed all new o rings and installed them in my car. Unfortunately I still haven’t gotten her to start up. But the new injectors that Scott gave to me fixed my no fuel pressure at the rail issue. Now when the pump primes the rail the pressure shoots up to 44psi then slowly drops to about 20psi where it stays. But it’s a Walbro pump so i don’t expect the rail to stay at full pressure. But when I crank the engine the fuel pump is definitely firing and the pressure shoots back up to 44psi where I have it set at. The new injectors definitely solved one of what looks like many problems I’ve got.
Unfortunately i had a other full blown asthma attack and I spent 12 hours in the hospital er. My next step is to pull my scan master off my other WE4 which I really don’t want to do because that car is sacred to me in a very way that still upsets me sometimes. But I’m gunna do it anyway. I was hoping that one of these local central Florida club members had one for sale but no luck there. But yesterday I was supposed to do a full contact clean up on the fuse block as well as replace all the fuses good or not and check the setting of the tps and iac and message it to Scott who has been a huge help to me. So hopefully tomorrow I will have an update with some better news. But my old injectors were definitely leaking because my plug are clean but definitely stink of gasoline.
So that’s about it. Other then having very painful chest pain upon breathing from that asthma attack and the intubation tube inflammation making it hard to speak. See I have no desire to sell my car. I spent thousands on parts that I haven’t even opened up yet. But setbacks like that are what push me to post it on Craigslist for sale. But tomorrow morning no matter how shitty I feel I’m going to that car and I’m gunna spend all day cleaning that fuse block and going over all the wires under the dashboard. I even found out that the ignition switch could be causing this if it’s dirty enough.
I replaced all the lights in my gauge cluster as well as the ribbon wire with a Casper’s one With the charge resistor soldered into it to keep the alternator charging even if the light goes out. Now since I bought this car 4-5 lights have never worked and still don’t work
1) oil/choke
2) volts
3) temp
4) brake
I forget the last one. But the o my lights that work are the turn signal lamps and the check engine light.
Also the power windows and door locks never worked. But the motors are good because I bypassed everything to test the motors and they all work. So I really think I need to take a look under that dash for a problem. Just for the hell of it here is a list of everything I replaced that is relevant to the no start. Just an FYI everything I replaced was actually broken or covered in bee hive. I never replace working parts.
1) Ecu (was the reason seller stopped driving the car 20 years ago. Ecu had no fuel pump trigger). I again replaced the Ecu free under warranty just Incase it was the issue
2) fuel pump,tank, soft lines, filter, regulator, Walbro 255 pump , kirban fpr.
3) battery
4) ignition coil (oem was still good but I replaced it because I had to replace the ignition control module and I was told to replace both).
5) ignition module (was melted when I got the car. I replaced it again free under warranty 2 days ago)
6) crank position sensor
7) tps (ordered a cheap one. Once the car starts I will invest in a oem unit) I’m still waiting on it to arrive. My original one still works but cracked where it secured the plug pigtail.
8) IAC (same as the tps. Ordered a cheap one online. If this car runs again I will gladly spend the money on an oem unit). I am still waiting on this to be delivered to me.
9) new negative battery cable
10) new positive battery terminal
11) Delco spark plugs

And I’m sure a bunch of other things. But everything I replaced except for the original coil pac, tps,and iac was actually bad when I got the car. The ignition control module actually leaked out all that Carmel onto the back of the engine and the knock sensor. And the car still ran but was missing. That wax a pita to clean up.

Well anyway have a goodnight guys/girls. Tomorrow I will go head to head again with her all day.
Oh btw more good news. My powermaster also dies lol. Something doesn’t want me to finish this car. Lol.
 

87WE4!!

Active Member
Jul 2, 2018
173
50
28
Ok, I have another question. I’m sure it sounds stupid but I’m ready to throw In the towel.
Could it be that I didn’t prime the oil pump long enough to get all the lifters full of oil. Because honestly I did see oil at the middle pushrods on each side but I didn’t see oil at every single pushrod. And by drill burnt out that day because I was priming it for a while.
Maybe not all the lifters are pressured with oil and not all the valves are opening?

Other then that I got nothing.
 

mikestertwo

Well-Known Member
Sep 13, 2006
5,100
157
63
118
Warren, Oregon
Ok, I have another question. I’m sure it sounds stupid but I’m ready to throw In the towel.
Could it be that I didn’t prime the oil pump long enough to get all the lifters full of oil. Because honestly I did see oil at the middle pushrods on each side but I didn’t see oil at every single pushrod. And by drill burnt out that day because I was priming it for a while.
Maybe not all the lifters are pressured with oil and not all the valves are opening?
Other then that I got nothing.
The engine will still start. The valve train will just be noisy as hell until the lifters pump up after the engine starts.
 

87WE4!!

Active Member
Jul 2, 2018
173
50
28
The engine will still start. The valve train will just be noisy as hell until the lifters pump up after the engine starts.
Thanks for the reply.
I got nothing then. I’m literally stumped. I got spark, injector pulse, fuel pressure, air, compression. Idk what else the car wants. I have standing voltage at all the sensors.
No oil light
No volts light
No temp light
And no start

Today I cleaned the entire fuse box and replaced all the fuses. Except the 2 circuit breakers. Strange thing tho. I was looking at my tps and I had 5v standing voltage at the grey wire but nothing at the blue wire which is the wire you connect a volt meter to set it. It should still start without the tps connected right? I’m waiting on one I ordered.
 

87WE4!!

Active Member
Jul 2, 2018
173
50
28
Can you send some good pictures of you cam sensor without the cap on?
I’m headed back there tonight to go another round with her. Yes, I will post pics without the cap but idk what stroke the engine is currently on.
 
Top Bottom