Wonderful...CODE 31

Turtle TR

boioing boioing boioing..
Code 31 (wastegate solenoid signal failed) : Blown 10A ECM/SOL fuse, but............

Wonderfull, the SES light comes on. Took out the scanner and it emits codes 31 and 32. Just for kicks i reseted the ECU and took the car for a drive, punched it a few times and BAMMM!!! SES light comes back on. hooked the scanner back on and code 32 isnt present anymore, but 31 is still being shown. It's something about the wastegate and overboosting.:confused: Where should I start to check before ordering a new wastegate solenoid or a new wastegate? Also...is there anyway that codes 31 and 32 are related for being set off? Thanks guys!!!
 
Since the computer has no idea how much boost the car is running it would have to be either the solenoid or wiring. Make sure the plug is tight and clean. In other words it has to be an electrical problem, not mechanical.

What's a code 32?
 
32 is the EGR circuit...

I would check the wiring around there somewhere...I believe that the wastegate solenoid and the EGR solenoid use the same ground wire, but I could be wrong...
 
Ok, I checked around the wastegate solenoid and egr solenoid, and kinda blew air into the terminals to make sure they free from crap and moister inside (we recently had a freak rainstorm). plugged everything back in nice and tight. took the car out drove it regularly, and puched it out on the freeway. FRICKEN SES light turns back on. hooked back the scanner just incase code 32 emits as well. Only code 31 shows. The SES light doesnt come on when I start the car over again. I pops back on right after I throttle it really hard. Could this be the wastegate solenoid going bad? How do I check it to see if its working or not? Thanks.
 
If anyone can solve this problem, it will be a miracle. My car has done the same thing for several months now, even after replacing the wastegate actuator and solenoid! This code will NOT be set unless the car is at WOT for a couple of seconds and boost rises over about 15 psi or so. Once the SES light comes on, it stays on until the car is shut off. When restarted, the SES light is once again off, until...well, you get the picture!

Haven't seen a code 32, though. One odd thing I realized though, is that the first time I saw the code being set, I had just tried manually locking the TCC by shorting the two required pins in the ALDL connector. As soon as I shorted them, the car kind of sputtered, and there was the code 31! ...maybe totally unrelated, but maybe not...? After that incident, I see code 31 almost every time I stomp on it! Oh yeah, my convertor clutch has never worked, even when trying to lock it manually (probably a bad clutch solenoid or something).

The next thing I will try is a new terminal end for the harness (new plug for the solenoid). If there is an intermittant connection there, this will surely fix it. :D

If anyone has a solution, please let us know! :cool:
 
I just replaced my wastegate solenoid. Same code 31. :mad: no other codes assisting it. This is no fun. HELP!!!!
 
Check your wiring and also the grounds behind the AC compressor. The wastegate solenoid code will only set like you describe it. You have to get on the gas hard for a while for it to set. It's nothing mechanical. Look at the wiring and make sure the pins in the plug for the solenoid aren't bent or opened up. I have mine unplugged and it does the exact same thing as yours.
 
Thanks for the info cool84. I did use the A/C during our freak rainstorm, which happend the day before the SES light set off. and the A/C compressor is going bad too. can a bad compressor ground out something like that and set a code? wierd! Thanks again man!
 
Where exactly is it the ground? Is it along with that nest of wires bolted down to the accesory bracket? am I looking at the right place? Everything there seems to be in tact. I checked the plug and they arent bent or open. Maybe a pinched wire somewhere? CRAP!
 
The grounds are located on the bolt below the AC compressor that holds the alternator bracket to the head. There are 6 if I remember right and sometimes they corrode and break.

Another thing, and it's long shot but how often do you use the AC compressor? Make sure on the electrical plug to the compressor there's a diode in it. If not when the compressor clutch disengages it can send a voltage spike to the ECM and kill it.
 
Hows your wastegate actuator ? Binding or sticking ? Do you have good boost control ?
One other thing...did you reset the ECM after you replaced the solenoid ?

(remove positive lead on battery and wait for 10 secs then reconnect)
 
Cool84: I checked the plug on the a/c compressor, the diode is on. Kinda wierd though, The tape over it looked like regular duct tape. and one of the wires were stripped, but sill secured on to the plug :confused: I put a decent amount of electric tape back on, and plugged it back in. Just for kicks, I took off the a/c belt and ran the car, Id figure if the compressor isnt spinning, and if the compressor was part of the problem, then with the belt off...maybe a code wont show. haaaaaaah!! NO!! SES light comes back on. I checked around the grounds. I removed the bolt and cleaned up the wires eyelets and reinstalled them prior to taking off the a/c belt and checking for the diode. hmm..maybe the diode has gone bad? and if there was a voltage spike, what exactly would it kill? the whole ECM? the ECM Prom? Thanks again!

HOTSIX: I dont think that my actuator is the problem. my boost build steadily and holds at a set 15psi. It never goes passed 15psi. Maybe it is a mechanical problem? crap! I did reset the ECU, but maybe improperly, I didnt wait for at least 10 seconds. And I just disconnected the ECM fuse, rather than remove the battery terminal. I'll try that tomorrow morning. Thanks!


And the saga continues...............
 
:confused:

I disconnected the fuse, rather than take off the battery terminal. Is there any difference to removing the terminal vs pulling the fuse? Oh well:rolleyes: I waited for at least 10 seconds, I went back into my house to let my Dad know I was leaving for work (well over 10 seconds). I let the car idle for about 5 minutes and drove off normally. Hit traffic on the freeway, so I couldnt really punch the car out to see if the SES light would show again. Lunch time, I took the car out. the roads were busy again so I couldnt really punch it out. I found a small side street and gave the car WOT, but I couldnt hold it long, I had to brake because the street was ending. No SES light yet. Then I punched it again right before I got to my working place's driveway. No SES light yet. Hmm...still too early to say it's gone.

*keeping my fingers crossed*
 
Ya...I would try changing out the ecm. The SES diagnosis on the GN-Ttype web site says that is one of the solutions...although its the last one mentioned.

Conds for setting CODE 31

1) ECM commanding asolenoid duty cycle btwn 5% and 94%

2) NO electrical feedback is being rec'd from the solenoid

3) above cond's are met for more than 2 secs

Solutions

1) Poor or corroded connections btwn ECM and wastegate solenoid

2) Open or shorted solenoid

3) Defective, sticking or maladjusted wastegate linkage (thats why I asked about this one)

4) Defective ECM
Let us know what happens....
 
I'm going to my friends house tomorrow, also owns an 85 TR. He understands everything electrical about the car. I will also try out his ECM. If its my ECM, I'll let you guys know. Maybe its a calling to convert to the 86/87 ECM. CRAP, them 86/87 MAFs are expensive!
 
My friend, Gareth (85zoom) took out his Fluk meter and test the grounds. I recieved no ground and voltage was fluctuating. He took out his Chiltons Reference book and looked over the schematic on the wastegate solenoid. the wastegate solenoid was in line with the brake switch, EGR control, and purge valve solenoid (i think that's what its called), and they were in line with the ECM/SOL fuse. I checked under the dash, pulled out the 10A fuse and found it was blown. CRAP!! oh well...that was the culprit. Gareth provided me the new 10A fuse and plugged it back in. Took the car out for a run, and punched it from a stop, and from a 50mph roll. YAY!!! No light. we went back to my friends house, and I had to go back home. On my way home, the FRICKEN SES LIGHT TURNS BACK ON!!! I looked under the dash again to see if the fuse blew out again. sure enough the fuse blew. I replaced it and I called my friend back. He refered to the Chiltons schematic and suggested I take off the purge valve solenoid and run it again. On my way to the barbers, the SES light shows again. CRAP AGAIN!!! So I plugged back the purge valve solenoid. And I called my friend again, he said to unplug the EGR solenoid. I havent ran the car yet, there's no telling what might happen, till I run the car again. It can't be my brake switch, because I'm using a vacuum brake system. Or some brake switch by my pedal? isnt that the brake light switch? I dont know. Possibly its both. I was reading a section in gnttype.org about switches and came upon the TCC Defeat trick. Linking the brake switch into thinking the car had its brakes on and unlocking the Torque converter. Seems to complicated for me to understand the logic between the TCC, torque converter and the brake swich. I looked under the car, and there is 2 plugs attached to my pedal assembly, but on to what I think is the brake switch, seems logical. Where was I getting to again??? So possibly, my brake switch, if thats the one I'm looking at, could be bad also since its inline with the ECM/SOL fuse. Well...I didnt have anymore 10A fuse so, there's a 20A fuse in its place. So, when I run around town tonight and the SES light turns on with a blown fuse, its not the EGR solenoid. All that's left is the brake switch on my brake pedal assembly (if thats the same switch). Then I'd have to remove the brake switch plug, with the pink wire with the black stripe on the brake switch. If that still sends an SES Light and a blown fuse? Man...this sucks! Knowing the Chiltons manual isnt complete, is there other things along the ECM/SOL fuse that could blow it? Something has to be grounding out some where to make it blow. Weird thing though, I hooked up the scanner again to see any new codes. Code 31 is still present. Why? I have no idea. Another question, can a low battery cause my fuse to blow? seems like a retarded question, but my battery was reading less that 12V, which is understandable, with the key on the "ON" position, likely there would be load, possibly resulting the low voltage. When we took the readings on the EGR, the wastegate solenoid, and the MAF...they read 11.71V after changing out the fuse. Any suggestions from any of you guys??? Can the ECM cause the ECM/SOL fuse to blow? maybe a pinched wire? well...I'm going to find out soon if the EGR or brake switch is related to this. I'll keep you all posted. Keep the suggestions and ideas coming!!! Also, if any of you have a GM reference book...what else is tied in the ECM/SOL fuse other than those I mentioned? Thanks.
 
ACCKKK!!!! Take the 20A fuse out...NEVER use a fuse with a bigger amperage rating than the one that is supposed to be there...YOU WILL screw something more major than just popping a fuse!!!! Get some more 10A fuses and keep troubleshooting like you are doing...hell, leave the blown fuse in there until you get more of the right amp rating...
 
Back
Top